Community Forum

xFi Advanced Security is blocking my company's website

Highlighted
New Poster

xFi Advanced Security is blocking my company's website

One of my company's product domains is being blocked by xFi Advanced Security.

https://v2.hostfully.com is the subdomain that serves our guidebook platform, and it works fine when i have this featured disabled, but when i turn on xFi Advanced Security, I get a message (different depending on the browser) about not being able to load the page because a secure connection cannot be established.

 

Can this be investigated to find out why?    I had a similar issue about 4 months ago with Xfinity's "Protected Browsing" which was (at least then) powered by the categorization database at https://tools.zvelo.com/

fixing our negative categorization there resolved the issue, but now a few months later the issue reappears even though Zvelo still shows our site as safe (as does every other categorization site i can find)

anyway,  any help to point me in the right direction would be useful.   At the moment i just tell any customers that report this to turn off this feature in xFi because it's buggy, but i'd like to solve the root cause.

Highlighted
Silver Problem Solver

Re: xFi Advanced Security is blocking my company's website

One option is to disable Advanced Security -

|You can disable the Advanced Security feature in xFi by navigating to More and selecting My Services. From here, select Disable under xFi Advanced Security and follow the on screen prompts. Once disabled, you will lose 24/7 threat monitoring and real-time reporting on your home network."


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

no, this is not a solution.   My question is about how to get Advanced Security to STOP blocking my website,  I'm already advising all customers who have this problem to disable this feature, but that's a temporary workaround, not a solution.

Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

phlarebot -- Thanks for reaching out.  I've pulled up your account & shared with engineering to take a look. I'll reach out when I have more information.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

phlarebot -- I will Private Message you with more information. Private messages can be accessed by clicking on the envelope icon in the upper right hand corner of any forums page. Thanks! Rachel


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

I am having similar challanges when I open the website https://jumpshare.com . It's critical to my business & causing inconvenience. Can you please look into this as well. 

Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

Xfinity advanced Security is blocking all of my companies websites as suspiscous...seems to be domain based because these are ll hosted differently. 

Please unblock... or tell us if there is a risk that we are not aware of to get it unblocked. 

Ascentsg.com, metrics.ascentsg.com, APP-UGX.ascentsg.com

Please help- I have called support 9 times and escalated with no success... they keep wanted to send someone to my house... but this issue is happning for many people in different locations. 

Thanks! 

Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

My company is experiencing this too, one of our domains appears to be blocked by this feature and our SSO uses this domain which means all of our sites are blocked when a user is using the advanced security feature. We have verified that it works fine when disabled but that's not really a solution. 

 

What are you recommending for customers? I'm happy to share more about who our company is in a DM. 

 

Thanks

Highlighted
Regular Visitor

Re: xFi Advanced Security is blocking my company's website

I have the same situation.  The Advanced Security is blocking our company website for our users (fantasygrounds.com); and generally causing all sorts of frustrated users who have Comcast and extra support calls.  The only thing we can tell them is to turn off the service; since I have not found any way to get whitelisted.

 

What can we tell our users who use Comcast?  How can we resolve long term?

 

JPG

 

 

Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

I understand your frustrations we have an engineering ticket in to assist with any website that is being blocked by xFi advanced security settings. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

This is beyond a nightmare.

 

Our traffic dropped off more than a year ago and I couldn't figure out why.  I got a call from a client who told me that Xfinity was giving them a message that the site was malicious.  Who knows how many people have been blocked from getting to our website.  I esclated this all through to engineering and it was resolved.  I just got another call from someone today that the site is being blocked.  

 

Our website is www.future-bright.com

 

First I had to wade through an infuriating number of people who wanted me to reset my router and all kinds of non-related things.  

 

This seems like it should be illegal.  We build websites for X sake and this has harmed us a great deal.

 

Highlighted
Regular Visitor

Re: xFi Advanced Security is blocking my company's website

This is a known Comcast/ Xfinity problem. We are having the same issue with selfmadewoman.com Godaddy advised us that they are receiving an extremely high level of complaints about their customers websites not working. They did 4 hours of trouble-shooting for me and said only Xfinity could correct it, but after 3.5hrs on the phone with 4 different people at Xfinity they have no resolution at all. It's their "Advanced Security" feature thats causing the problm. Works everywhere but on Xfinity. We pay them to be their customer so they can disrupt our businesses? Hmm.

Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

My company (www.beaconstac.com) is having the exact same issue with our domain qr.tapnscan.me which is being blocked by xFi Advanced Security for some unknown reason. 

 

This is having a major impact on our business as our QR code management solution uses this domain and some of the biggest Fortune 100 brands use our service on marketing materials and product labels. 

 

We really need help with this - we have no idea what caused it or how to resolve the issue. It is not an option for me to ask consumers to turn off xFi security because the end-users scanning the QR codes are not my customers - they're merely scanning the QR codes on package labels and other places. 

 

We need someone from Comcast to help with this.

 

- Ravi Pratap, Co-Founder & CTO, ravi@beaconstac.com 

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

My domains are also being blocked!  Who do we complain to?  This is just wrong!  How can a Museum site, Military related site, etc. domains get blocked!  HELP!

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

Another person with my problem was told that Comcast uses "company A" created blacklist.  I contact the "Company A" about my problem and requested my websites be removed from their list.  They acknowledged their partnership but said I have to deal directly with Comcast.

 

I worked with Comcast (chat mode) and the end result was to shut off Advanced Security so I can get to my e-mail and websites OR contact the company housing my website (which I did and they said they ARE NOT causing the problem)! 

 

In otherwords, anyone uses Comcast as their Internet Provider can no longer get to my websites?   My websites include a County Museum, Comic Book Store, Veteran's Museum, Navy Patrol Squadrons, etc.  They don't sell anything, etc. This is wrong!

 

Bottom line -  I can't get anyone at Comcast to do anything!  This isn't right!  All those Comcast users who access my sites - can't get to them if they are running Advanced Security.  This isn't right!

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Business site I've had for nearly 18 years, blocked since friday. I have to use VPN to access site that's green on every list. You must have defective filter on your new Advanced Security product, why not just remove it until you've fixed it? Thanks

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

   
New Poster - 
Re: xFi Advanced Security is blocking my company's website Business site I've had for nearly 18 years, blocked since friday. I have to use VPN to access site that's green on every list. You must have defective filter on your new Advanced Security product, why not just remove it until you've fixed it? Thanks

 

One of my sites "blacklisted now" has been on-the-air since 1996 (yes - 1996)  without one complaint!  Anyway, Advanced Security provides protection that I still want to take advantage of - so, I leave it on.  The bigger concern is all those Comcast Users who haven't a clue what is going on and simply can't get to our websites - period!   These Comcast users may not know about VPN.  Yea, we can run with VPN to get to our sites BUT that isn't the problem.  The problem is some faulty filter says our sites are dangerous and Comcast prevents them from seeing our sites.   No one seems to be able to correct the problem.  They are causing damage to us!   Wouldn't be surprised if a lawsuit pops up when they blacklist the wrong site!

 

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Sorry to hear about your experiences, it looks like they've had this issue for some weeks. Only an issue with Comcast.  AT&T & Frontier are fine.

 

I don't know who their "security" vendor is, but looks like neither has escalated. I can't believe its about tech competence,  just poor response  so looking for workarounds like VPN. Sad to be trying to solve when they have so many techs . .

 

DNS propagation is fine for rest of world, you can check here

 

https://dnschecker.org/#A/

 

Also has tools like blacklisting, your domain ComicBookStore.com is clean.


Trying access through xfinity wifi,  turned it on but apparently takes time to come up, I've got a feeling the same junk is blocking that.  If I find anything will post.

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

Thanks for your comments  - I checked all my domains and non are blacklisted.  I finally got Comcast to elevate my complaint to the next technicial level - will have to call this morning after 8AM.    Finally, got a representative to elevate me up the food chain.  Will let you know what they say.  Oh yea, one of the threads mentioned that they thought Plume handled the lists for xFi Advanced Security - got through to Plume and they said I would have to go through Comcast.  😞

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

UPDATE (6/1/2020):  Worked with (next level) Comcast Support from 8:03 to 8:52 AM.    Unfortunately, while I can't get to any of my sites - the representative (running through xFi Advanced Security also) could get to all my 5 sites!  He was at a loss why he could and I couldn't.  He said he would call me back after he checked into a few other possibilities.   Also, I got the impression that he wasn't aware of anyone else having the same problem - I pointed to just 2 of many threads for him to review - it wasn't just me.  So - still dead in the water with my websites.   He said he would call me back today - keeping my fingers crossed.

UPDATE (6/2/2020):  Still waiting for the "call back!"

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

@NFrankel236 @ComcastRachelH,

 

Guessing responding Comcast tech may be outside your network or US,  may not be able to replicate the block. Your hosting technician will not see a problem either, if they are not using Comcast.  Their blocking  rule doe not appear not consistent.

Also tested  with Browsec plug-in switching  to non Comcast NY server,  not blocked from there either.  I'll post any progress.

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

Actually, he was about 240 miles away.

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Try command prompt as admin, will go to:


C:\Windows\system32>

 
type in :

tracert  yourdomain.com 

you can check where it's being blocked

 

https://kb.intermedia.net/article/682

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

 
XL9 - Thanks for the suggestion.  Take a look at this thread:  https://forums.xfinity.com/t5/Your-Home-Network/xFinity-Router-Gateway-is-blocking-a-specific-websit...
I ran all the traces with and without VPN running.
Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

UPDATE (6/1/2020):  Worked with (next level) Comcast Support from 8:03 to 8:52 AM.    Unfortunately, while I can't get to any of my sites - the representative (running through xFi Advanced Security also) could get to all my 5 sites!  He was at a loss why he could and I couldn't.  He said he would call me back after he checked into a few other possibilities.   Also, I got the impression that he wasn't aware of anyone else having the same problem - I pointed to just 2 of many threads for him to review - it wasn't just me.  So - still dead in the water with my websites.   He said he would call me back today - keeping my fingers crossed

UPDATE (6/2/2020):  Still waiting for the "call back!"

UPDATE (6/3/2020):  Still waiting for the "call back!"

UPDATE (6/4/2020):  Still waiting for the "call back!"  Getting a feeling that the 2nd Level Support Representative blew me off? 🙂

UPDATE (6/5/2020):  Still waiting for the "call back!"

UPDATE (6/6/2020):  Still waiting for the "call back!"

UPDATE (6/6/2020):  OMG - As of 5PM (or so) -  I am no longer blocked!  Yes, I am now living the dream!  FWIW - all my websites were blocked from May 29th, through June 6th, 2020.

UPDATE (6/7/2020):  Yuppa - BLOCKED AGAIN!

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

UPDATE (6/7/2020):  Yuppa - BLOCKED AGAIN!

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Check your ip
https://www.wikihow.com/Check-a-Computer-IP-Address


Check if your ip is blacklisted by anyone
https://whatismyipaddress.com/blacklist-check

 

I found this had been an issue,

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

Thanks - my IP doesn't show up on any blacklist.  I also got the IP address for my biggest site (on the air for 24 years without a problem and being blocked) and it showed all blacklists site checks as GOOD.

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

This is happening to us as well.

Advances security flagged our site and now we cant get it.

Tried disabling "advanced security" but still can't get it

I have been on support for 4+ hours, getting tossed to many different people who cant help

absolutely horrible service

Highlighted
Expert

Re: xFi Advanced Security is blocking my company's website


@XL9 wrote:

Check your ip
https://www.wikihow.com/Check-a-Computer-IP-Address

 

 

FWIW, if one is behind a router, that method will only show one's LAN / private IP address. Not one's WAN / public IP. You would need the computer to be directly connected to a straight cable modem.

 

Sites like this will;

 

https://www.whatismyip.com/


 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Not an IP issue

Highlighted
Expert

Re: xFi Advanced Security is blocking my company's website


@josephpannone wrote:

Not an IP issue


I didn't say that it was. I just was replying to others with some info.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

I'm having the same problem accessing my company website.  I'm able to access it on my iphone when going through the Sprint network but not from my home xfinity network.  I have disabled XFi Advanced Security but it is still not working. When I do a traceroute I get a "Request timed out" at hops 9,10,11,12,13, and 14 and then get a message that "destination protocol unreachable".  Please help.

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

My domains are also being blocked!  Who do we complain to?  Going on 5 days now!

Support keeps asking the same questions.

Comcast acknowledges this is their issue, but won't fix it!

 

Highlighted
Regular Contributor

Re: xFi Advanced Security is blocking my company's website

Let's face it - THEY DON'T CARE!   I have a bunch of sites being blocked as well - THEY DON'T CARE!

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

I found a workaround.

 

I switched from the Comcast DNS to another and I can get to my sites.

 

 

Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

Xfi was completely blocking my Mac from connecting to my wifi.  I had to shut off "Advanced" Security to remedy.  Basically Xfinitiy decided that my companies security software was a risk.  Cost me 3 days.  Be looking for alternatives to comcast in the near future.

Highlighted
Regular Visitor

Re: xFi Advanced Security is blocking my company's website

Comcast/Xfinity,

 

I'm having the same issue, what is the deal? I cannot access any of our corporate websites all of a sudden. This is a major issue that needs a quick resolution.

 

Turning off advanced security is NOT a solution. How am I supposed to advise potential customers using xFi? Our websites utilize a shared IP and run on a secure server that has a real-time Malware scanner/blocker. This is not a shared hosting setup, this is a Managed VPS setup.

 

We need a solution ASAP.

 

Kind regards,

John

Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

Hi @johnnybravo1  We understand how upset everyone on this forum is about their website being blocked by the xFi advance security and we have a ticket put in to fix the issues.  We will need you all to post the URL of each website and we will add those to the list with the others we already have.  We do have a ticket linking all of them together to be unblocked etc.   Thanks again we are doing it as fast as possible!  The only thing that can be done in the time being is for each person trying to access a blocked website to turn off advanced security etc. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

After 2 weeks clear,  getting blocked from work website again.

-Can get through with vpn
-Website is clear of all blacklists
-Comcast ip appears on 3 blacklists,   guessing that could be the culprit.

When things work, Comcast is the best service around, you also pay a premium price for it to run properly.

This  issue has remained unresolved for far too long. I  believe that Comcast has experts who can solve this, but there's not enough similar cases to justify a systemic issue &  layers of incompetence holding up a fast fix. For that reason, unless catastrophic, I generally avoid going through Comcast support ladder, wasting a lot of time on script jockeys,  getting to a qualified tech.


Thanks for trying though.

 

 

 

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

Forgot add Comcast ip, is on the following blacklists.

 

dul.dnsbl.sorbs.net
dnsbl.spfbl.net
dnsbl.sorbs.net

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

I cannot access:

www.cwdash.com 

www.forzadash.com

 

I believe it's something the sites are referring to that you have blocked.  

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

I turned off "advanced security" that does not help.  Read the thread above, please.

Highlighted
Frequent Visitor

Re: xFi Advanced Security is blocking my company's website

FYI, I can access your sites on  comcast

Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

Our website is also getting blocked by xFi Advanced Security so many Xfinity/Comcast users can't access our website right now. When many Xfinity/Comcast users visit our website they see this (or similar) error message no matter which browser they use:

SSL_PROTOCOL_ERROR

And the only way they can access our site is to go into xFi Advanced Security settings and disable it. Once they do this, the site loads fine. When visitors go into their xFi Advanced Security "threat history" it says "1 suspicious site visit" and then it says "content from ____________ was blocked" (our website URL is listed; however, I do not want to post it publicly because it could hurt reputation). And this block is causing this error which prevents Xfinity/Comcast users from visiting our site.

Our site is 100% safe and clean and always has been. We're not on any type of blacklist and no other ISP or security programs have issues with our website. This is a false positive in the xFi Advanced Security settings and we need Comcast/Xfinity to whitelist our domain so this stops happening as soon as possible.

In this thread @ComcastJosh says he will whitelist domains that are being accidentally blocked by xFi advanced security. So we would like to know how to get our website whitelisted as soon as possible because this block that xFi Advanced Security put into place is really hurting our small family run business right now.

Please private message me to get website URL. I do not want to publicly post our URL since it will do additional damage to our reputation.

Highlighted
Regular Visitor

Re: xFi Advanced Security is blocking my company's website

Hi All,

 

After 3 days of banging my head against my screen and multiple calls to Support with no resolution. I figured out what was causing my problem. Unsecure FTP.

 

I have 27 websites running off a single IP, when I FTP into each, I usually do so over SFTP. One of my FTP accounts was connecting over standard FTP.  I tested this theory and I was able to recreate the block.

 

First thing you need to do, log into your Xfinity account online, go to Internet > Network > Advanced Security. From here, click on your device, if you see "Unauthorized Access Attempt" chances are you are facing the same problem I did. Don't click "Help Me Fix It" because it won't. Instead click "More About This Threat" and then Click on "Threat History" you should see your sites IP address there with a message like; "Are you or someone you know trying to access this device" and a random port number. Click allow access, and see if you can now access your site.

 

Try connecting to FTP unsecure again and it will trigger another block. I did this several times to confirm that FTP was the culprit. I re-setup my FTP connnection to use SFTP and tried this experiment again and all is well. No more blocking.

 

One thing that helped me in this process was https://downforeveryoneorjustme.com/ - Everysite I tested was just down for me. 

 

Hopefully this helps someone.

 

Kind regards,

John

Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

@Elkcubra  I sent you a message please reply back with your company URL in the private message thanks and i will send it over to be whitelisted. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: xFi Advanced Security is blocking my company's website

To everyone that has blocked websites or URL's of your companies etc please DM me them all and i will send each of them to get whitelisted.  No ETA on resolution thanks again for your patience and we appreciate all of you! I understand your frustrations we have an engineering ticket in to assist with any website that is being blocked by xFi advanced security settings. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: xFi Advanced Security is blocking my company's website

Hello, my website is also having this issue. It used to work, but was randomly blocked earlier this week. We have gone through all of the troubleshooting steps, Comcast support was of zero help, and the issue persists. As previous contributors have said, this is accessible through any other ISP and through cellular networks. Host is not blocking my IP. We also need our website to be added to the whitelist. Domain is: thedrivenexchange.com

 

We have been Comcast customers for two decades, and cannot belive that we aren't being offered better support. We need this to be fixed as soon as possible.

 

 

@ComcastJosh 

New Poster

Re: xFi Advanced Security is blocking my company's website

@ComcastJosh  I tried loading the site again today and it's still giving me this message:

Hold On!


This site might compromise your device or contain dangerous content.
To avoid these risks, close this window and skip this site.

Any ETA on when this issue will be resolved?