Community Forum

xFi Advanced Security blocking port 8000

Highlighted
Regular Visitor

xFi Advanced Security blocking port 8000

I am using port forwarding on an xFi gateway to access my surveillance cameras when away from home. Everything worked fine until recently when xFi Advanced Security was enabled on my gateway.

 

I access the cameras using port 8000. I can access the cameras away fromhome when I disable xFi Advanced Security. But when I re-enable Advanced Security, I once again cannot access the cameras.

 

I used a port-checking utility that confirmed that I cannot access port 8000 from outside the network when Advanced Security is enabled. The app also alerts me that it is blocking a threat when I try to acess port 8000 from outside the network.

 

So, is there a way to keep xFi Advanced Security enabled yet still access my cameras from outside the network?

Highlighted
New Poster

Re: xFi Advanced Security blocking port 8000

I have found that xFi Advanced Security blocks any port that I try and forward. If you are quick then you can get get about one port scan to show that it is open before it gets blocked again. DMZ mode is getting blocked in the same way, so don't bother with it either.

 

Within about 5-10 seconds (the prompt says that it can take up to 10min) of turning off the "Advanced Security" the port is forwarded and all is well.

 

This is definitely a software bug on the gateway. Until Xfinity fixes it there is nothing else we can do.

 

Although I kind of liked the other features of advanced security, I am just going to put my Advanced Gateway back into bridge mode and run my own firewall/router behind it.

Highlighted
New Poster

Re: xFi Advanced Security blocking port 8000

And DONT call internet technical help- i spent 2 hours trying to explain this exactly...i was transferred to 3 people, and they said i had to separate my WiFi into a 2.4 and 5....well that kicked out every device we have and need to resign in every home automation device !! And then the kicker - it still doesn’t work!

it is definitely related to the new enhanced security and turning it off solves the problem and the techs have no idea how to help

Highlighted
New Poster

Re: xFi Advanced Security blocking port 8000

You have to disable xFi advanced security. To do this: download the xFi app, click “More” at the bottom, scroll down to “My Services,” select “Disable” and change the toggle button to off. That will disable all the automatic blocking of external devices trying to access your home network (i.e. when you want to access security cameras from your phone, work, coffee shop, etc.)