Community Forum

Xfinity xFi App not working.

Highlighted
New Poster

Xfinity xFi App not working.

We recently moved to a new apartment and everything seems to be working fine my gateway is online and working but when I try and log in to the xFi app it says "Sorry, we're having some trouble activating your gateway. Give us a call so we can get you up and running" I know the app worked before so im wondering what happen?

Highlighted
New Poster

Re: Xfinity xFi App not working.

Did you get this fixed?  Same thing is happening to me  Unable to use the app since the move last week.  I've wasted hours on the phone with Comcast and their supposed tech support tier 1 and tier 2.  They all can't seem to understand why.  Just keeps saying it's working on their end, which I don't care.  It's not working on my end so I can't control my Xfi gateway and my pods because some "genious"  at Comcast though it was a great idea to only be able to control them through an app.  

Highlighted
Valued Contributor

Re: Xfinity xFi App not working.


@sanjosalien wrote:

We recently moved to a new apartment and everything seems to be working fine my gateway is online and working but when I try and log in to the xFi app it says "Sorry, we're having some trouble activating your gateway. Give us a call so we can get you up and running" I know the app worked before so im wondering what happen?


@HotInEER1 wrote:

Did you get this fixed?  Same thing is happening to me  Unable to use the app since the move last week.  I've wasted hours on the phone with Comcast and their supposed tech support tier 1 and tier 2.  They all can't seem to understand why.  Just keeps saying it's working on their end, which I don't care.  It's not working on my end so I can't control my Xfi gateway and my pods because some "genious"  at Comcast though it was a great idea to only be able to control them through an app.  


 

@sanjosalien & @HotInEER1 

 

If you have recently moved, are you using your new account email and password?

 

Unless Comcast moved your old email to your new account you are probably authenticated with your old account and that is why you are having issues. Comcast now allows you to keep an email active although the account is closed and I think this can create confusion for a lot of people who moved.

 

My recommendation is to either have Comcast move your old email to the new account or set up a new email and password for the new account and try using the xFi app with that new account information. 

 

Let us know if this is not the case or if this resolves it.