Community Forum

Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Highlighted
Regular Visitor

Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Hello,

 

I recently swapped my XB6 Gateway (Shiny Dark Gray) for the XB7 Gatway (White/Gray). I did the self-install which meant launching the xFi app, and completing the swap of the XB6 to XB7. This took about 30 mintues and I was up and running - all 45 devices connected to the Gateway. I use the Apple Ecosystem - so iPhone/iPad + HomeKit along with the following WiFi Smart Home devices:

  1. Ecobee 4 Units
  2. MyQ Garage Door openers + Homebridge
  3. Logitech Circle 2 HomeKit-enabled cameras
  4. Nest Protects
  5. Philips Hue Bulbs

I noticed that after switching to the XB7, the Ecobee 4's, MyQ were not longer accessible via Home app in Apple HomeKit. But, in the actual Ecobee or MyQ apps, they were completely accessible, same with the cameras. The Philips Hue bridges are connected through Ethernet, and those are all accessible.

 

I attempted removing all of the non-responsive equipment from HomeKit, and now they will not add back in. I have never had this issue. 

 

Tonight, I also just decided to re-add the MyQ garage door openers to the actual MyQ app, and that wifi setup process is also not working. You start the setup process on the garage door, and attempt to connect the garage to your home network, and it fails, just like the HomeKit devices were.

 

I am beginning to think there is some setting on the gateway that I'm missing that is not allowing these devices to connect.

 

Other than that, the gateway is great, is faster, and has better range overall.

 

I have not tried a full reset of the gateway, but I have logged in/logged out of iCloud, and tried different devices.

 

Has anyone had an issue paiting smart home devices to the Gateway at all?

 

Thanks!
Ajax

 

 

Highlighted
Official Employee

Re: Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Hello @iajax  yes there are still some known issues that we are working through with some devices including  the Ecobee theromostat etc.  We are pushing new firmware that fix some of these known issues,  so at this time if they will not connect and you need to be able to use all of the devices and they worked great with the XB6 then please go back to it until the bugs are worked out.  I have already spoken  to our engineer's in Philly recently about some of these issues with some devices. 

 

"Thank you for the compliments on the XB7 and we are hearing great things about it as well"


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Expert

Re: Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

If you have access to the gateway admin panel ( http://10.0.0.1  ) try turning off the 5 GHz band temporarily, add the devices back, then turn it back on. 

 

 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Contributor

Re: Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Your gonna need to set up a new home, thats how Apple homekit is unfortunately. The devices need to be factory reset as well so they forget all the previous settings. I had to do that for just one device that wasn’t working once I did it all worked fine. Good luck
Highlighted
Regular Visitor

Re: Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Hi! This is actually what fixed it. But, after about 1 week, the MyQ (2.4GHz device) shows no response again, but in the vendor app it’s fine. I have also split the networks to be 2.4/5. Any other ideas?

Thanks!!
Highlighted
Contributor

Re: Xfinity XB7 Gateway - Smart Home Devices Not Pairing HomeKit / Direct

Is your 2.4ghz set to one certain channel or is it automatic? I have mine to a set channel well both 2.4 and 5 just to avoid the stupid little devices from getting confused.