Community Forum

Xfi Pods Will Not Activate

Highlighted
Regular Visitor

Xfi Pods Will Not Activate

@ComcastRachelH

 

I have 6 Xfi Pods that dropped their connection a few weeks ago.  I was unable to reactivate them.  As a result, I recieved a new Gateway.  I am still unable to activate any of the pods.  I was on with Advanced Support for over an hour.  The agent tried several things as well as having me sign out of the XFi App, deleting it, then reinstalling it, and retrying the activation.  In addition, I tried using a different phone to activate them.  Nothing worked.  I keep receivng the message "Let's Try That Again"  Then we got disconnected and when I tried to call back was placed on another extended hold.   The serial numbers of the pods I'm trying to activate are:  

3S70A01080
3S70A07E91
3S70A01053
3S70A01060
3S70A00818
3S70A07E9A

 

My case number is CR874 815 348.  Any assistance you can provide would be appreciated.  

 

Thank you. 

 

Highlighted
New Poster

Re: Xfi Pods Will Not Activate

I have similar issue.  I had 3 Pods go offline i was told by Comcast support to take them to Xfinity store and swap.  I did that today, got the new Pods home and I'm still unable to connect the Pods to my network.  i get the message "Well that didn't work...." try again or go back