Community Forum

Xfi App Not Working

Highlighted
New Poster

Xfi App Not Working

Received the modem from Xfinity today and it was set up via a tech rep but the app says that it can't activate the gateway. I uninstalled and reinstalled the app but get the same message.
Highlighted
Official Employee

Re: Xfi App Not Working

We are sorry to hear that you are experiencing difficulties.  You can also log in Xfinity xFi by using the following link: http://xfinity.com/myxFi

 

Also, be sure that you have a Wireless Gateway that is compatible with the xFi App. The following link will let you see a list of the compatible Wireless Gateways: https://www.xfinity.com/support/articles/broadband-gateways-userguides

 

We hope this helps. If it does not help, please let us know. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Xfi App Not Working

Hi, I have the leased Xfi modem. I'm starting to believe, because I couldn't get in through the browser either, that my log in is auto connecting to my old address. How do I get that removed?
Highlighted
Silver Problem Solver

Re: Xfi App Not Working

You might find some clues by looking at your Account.

https://customer.xfinity.com/#/settings/account


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
New Poster

Re: Xfi App Not Working

Thank you! That has been an headache of mine for over a year. The customer service reps all acted like they had no idea what I was talking about (right after asking if I still lived at the old address). Everything works now! Thank you again!