Community Forum

XFi App connected devices not showing

New Poster

XFi App connected devices not showing

I just got a new gateway and installed with some help from customer support yesterday. I had previously been using the old gateway as a pass through to my own router, but was impressed with the XFi app and the management and control options available there, so this time I’m using the gateway as modem and router. It’s been connected for 24 hours, and still only shows 1 device (an Xbox One gaming console) as connected. There are 3 iPhones, 1 iPad, and a Netgear WiFi extender actively connected via WiFi. Additionally, an Xbox One, PC and HP printer are connected via wired connection.

Why are my devices not showing as connected so that I can assign and manage them? This is one of the primary features that I would like to be able to use.

Gateway model # is DPC3941T.

Thanks
Official Employee

Re: XFi App connected devices not showing

Hi @JarredE, this was a known issue a while back. It's since been resolved, however it does look like you have an older version of firmware on your device. Can you please try rebooting your Gateways two times to get the latest firmware version loaded?

 

To reboot, you can either:

1. Unplug the Gateway's power cord, wait 10 seconds and plug it back in. Once the Gateway comes back online, unplug it again, wait 10 seconds and then plug it back in. 

2. Trigger a Gateway restart through xFi (from the bottom of the overview page), wait until xFi shows your Gateway as Online and then trigger another restart from xFi. 

 

You can check your firmware in xFi under Network > Gateway > Gateway Details. You should see the firmware update from the current "DPC3941_3.3..." to "dcp3941_3.12..." after the reboots. If it does not, please reach back out and we can troubleshoot. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!