Community Forum

Wifi issues

Highlighted
New Poster

Wifi issues

I recently upgraded my Xfinity tonthe 500mb plan. Currently, my new network is listed and showing on my mobile devices, but my network isnt listed in my available network section on my pc. My home has 2 different networks showing on all of my other devices. I ran a speed test to see why my pc was running slow, and my download speed came back at 33.6. My mobile device came back at 346.5. My mobile is connected to the new network, but the pc doesnt even show the new network as an option. I tried adding the network, but the pc cant find it. Any thoughts on how i can fix this?
Highlighted
Silver Problem Solver

Re: Wifi issues


@Cwbygeej wrote:
I recently upgraded my Xfinity tonthe 500mb plan. Currently, my new network is listed and showing on my mobile devices, but my network isnt listed in my available network section on my pc. My home has 2 different networks showing on all of my other devices. I ran a speed test to see why my pc was running slow, and my download speed came back at 33.6. My mobile device came back at 346.5. My mobile is connected to the new network, but the pc doesnt even show the new network as an option. I tried adding the network, but the pc cant find it. Any thoughts on how i can fix this?

Sounds like a network issue.  Try the Your Home Network Forum.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Diamond Problem Solver

Re: Wifi issues

How are you doing a speed test on the pc if you can’t see a network?

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!