Community Forum

Re: Network Not Showing Up on Devices?

Highlighted
New Poster

Re: Network Not Showing Up on Devices?

My gateway was installed today and the system says everything is working, however the network will not show up as an available network on any of my devices. Cant get any help from XFINITY Assistant. What do I do?

 

Highlighted
New Poster

Re: Network Not Showing Up on Devices?

Hi!

 

I had the same issue. Brand new Xfi Gateway (3rd generation) installed with same network names (2.4 & 5.0) as the networks on my previous gateway. In my case, two (computers) out of close to 20 devices did not see the network being broadcasted, even though other device standing right next to them saw the networks without any issues (and both computers were invisible on the Xfi App).

In my case, going into computer settings and updating the network adapter driver did the trick (Control panel \ Network & Internet \ Network & Sharing Center \ Wifi Status \  Wifi Properties \Networking \ Configure \ Driver \ Update Driver)!

After updating, the two computers were able to see the network right away.

Hope this helps!

Highlighted
Official Employee

Re: Network Not Showing Up on Devices?

@TnRiddles  Can you please call 1 800 266 2278 and ask to speak to someone in the internet troubleshooting department because they would need to be able to pull up your account to troubleshoot why your network is not coming up on some devices.  If you are able to change your network name and then change it back that should also fix it but you have to be connected to the internet on one of the devices to do that.  Here are some links on how to change your network name that triggers it to work again etc 

 

https://www.xfinity.com/support/articles/view-change-wifi-password


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!