Community Forum

Port Forwarding for Minecraft Server Not Working

Highlighted
Regular Visitor

Port Forwarding for Minecraft Server Not Working

I've been hosting an MC server for months without issues, but within the past couple days other people can't connect to it. I've had people try to connect when I temporarily disabled Windows Defender Firewall, Java Platform SE binary can communicate to both private and public networks, I've temporarily disabled Advanced Security in the xFi app, I've had people try to connect via my IPv4:25565 and IPv6:25565, deleted and recreated the 25565 port forward, and none of the mentioned methods work. I believe the issue lies somewhere in the port forwarding of the server, but I'm also starting to think there may be an issue on the backend with Xfinity that is out of my control.

Highlighted
Expert

Re: Port Forwarding for Minecraft Server Not Working

Try disabling the Xfi Advanced Security feature as a workaround for now and see. It's buggy ! And there is currently no way for an end-user to be able to whitelist anything;

 

https://www.xfinity.com/support/articles/using-xfinity-xfi-advanced-security



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Port Forwarding for Minecraft Server Not Working

Is this an automated reply? I just said I already tried that.

Highlighted
Expert

Re: Port Forwarding for Minecraft Server Not Working

Sorry, my bad. I overlooked it. Please forgive me.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Port Forwarding for Minecraft Server Not Working

I was having this same problem for the past couple of weeks and just fixed it today. Here is what I did:

1) Navigate to your network settings and disable your ipv6 address

2) Delete your port forward for minecraft in the Xfi app

3) Restart your computer

4) Port forward minecraft to your device again

 

Xfinity doesn't have their port forwarding correctly setup to port forward to your IPv6 address which is set as the default address if turned on. So turning off your IPv6 address will allow your IPv4 address to be used in the portforwarding process instead.  I strongly recommend that Xfinity allows users to use the admin tool for portforwarding again so that this problem will not continue to occur.

Highlighted
Regular Visitor

Re: Port Forwarding for Minecraft Server Not Working

No luck with that method unfortunately.

Highlighted
New Poster

Re: Port Forwarding for Minecraft Server Not Working

I am now having the same issue. Even moved the server into the dmz and no one can see it. Any ideas?

 

Highlighted
Regular Visitor

Re: Port Forwarding for Minecraft Server Not Working

@bwood91 No luck unfortunately. Been having this issue for a month and a bit and still no luck. Have you tried the typical methods, such as the method mentioned above, temporarily disabling your firewall, allowing Java SE Binary as an exception to your firewall, etc.?

Highlighted
New Poster

Re: Port Forwarding for Minecraft Server Not Working

open Xfinity Xfi app > click ur wifi name right on top next to the wifi icon > tap on "Advanced Security"  > click the computer ur hosting on > Unathorized Access Attempt > Threat history> Allow Access