Community Forum

Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

Highlighted
Frequent Visitor

Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

I ordered the Gigabit Ethernet Internet Package and the XB6 (Model Number TG3482G) Advanced Gateway from Xfinity, when looking in Gateway>Hardware>LAN Ethernet I see that Ethernet Port 1 shows a connection speed of 100 Mbps. The spec sheet for this modem shows gigabit ethernet ports.

LAN Ethernet Port 1

LAN Ethernet link status: Active
MAC Address: {Removed this as its probably a bad idea to share?}
Connection Speed:100 Mbps
 
When I try the other port, I get the same thing, other than the MAC Address being one digit off...
 
I have completed the following Troubleshooting steps:
  • Restarting Modem
  • Restarting Computer
  • Trying Second Port
  • Trying Different Cable
  • Updating Ethernet driver on my computer

My computer is an AMD Ryzen 5 2600 on an MSI B450 Tomahawk Motherboard running all of the latest drivers. My Ethernet Cable is 20m of Cat5e, so in theory, the cable shouldn't be a problem.

 

I would appreciate any insight or assistance with my problem.

Highlighted
Problem Solver

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?


@RHeptner wrote:

I ordered the Gigabit Ethernet Internet Package and the XB6 (Model Number TG3482G) Advanced Gateway from Xfinity, when looking in Gateway>Hardware>LAN Ethernet I see that Ethernet Port 1 shows a connection speed of 100 Mbps. The spec sheet for this modem shows gigabit ethernet ports.

LAN Ethernet Port 1

LAN Ethernet link status: Active
MAC Address: {Removed this as its probably a bad idea to share?}
Connection Speed:100 Mbps
 
When I try the other port, I get the same thing, other than the MAC Address being one digit off...
 
I have completed the following Troubleshooting steps:
  • Restarting Modem
  • Restarting Computer
  • Trying Second Port
  • Trying Different Cable
  • Updating Ethernet driver on my computer

My computer is an AMD Ryzen 5 2600 on an MSI B450 Tomahawk Motherboard running all of the latest drivers. My Ethernet Cable is 20m of Cat5e, so in theory, the cable shouldn't be a problem.

 

I would appreciate any insight or assistance with my problem.


What is your computer's ethernet port speed setting?

Joe V
(not a Comcast employee, just another paying customer)
Highlighted
Frequent Visitor

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?


@jav6joev wrote:

@RHeptner wrote:

I ordered the Gigabit Ethernet Internet Package and the XB6 (Model Number TG3482G) Advanced Gateway from Xfinity, when looking in Gateway>Hardware>LAN Ethernet I see that Ethernet Port 1 shows a connection speed of 100 Mbps. The spec sheet for this modem shows gigabit ethernet ports.

LAN Ethernet Port 1

LAN Ethernet link status: Active
MAC Address: {Removed this as its probably a bad idea to share?}
Connection Speed:100 Mbps
 
When I try the other port, I get the same thing, other than the MAC Address being one digit off...
 
I have completed the following Troubleshooting steps:
  • Restarting Modem
  • Restarting Computer
  • Trying Second Port
  • Trying Different Cable
  • Updating Ethernet driver on my computer

My computer is an AMD Ryzen 5 2600 on an MSI B450 Tomahawk Motherboard running all of the latest drivers. My Ethernet Cable is 20m of Cat5e, so in theory, the cable shouldn't be a problem.

 

I would appreciate any insight or assistance with my problem.


What is your computer's ethernet port speed setting?


1.0 Gps

speed.JPG

Highlighted
Problem Solver

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

Can't see your picture.  Is your network adapter's speed/duplex set for auto negotiation or a manual selection?Network Connection.jpg

Joe V
(not a Comcast employee, just another paying customer)
Highlighted
New Poster

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

I’m having the same exact issue with my xFi Router I’m paying for 600mbps
Highlighted
Frequent Visitor

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?


@jav6joev wrote:

Can't see your picture.  Is your network adapter's speed/duplex set for auto negotiation or a manual selection?Network Connection.jpg


It is set to Auto-Negotiation. 

Highlighted
Problem Solver

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?


@RHeptner wrote:

It is set to Auto-Negotiation. 

Do you have the option to choose 1 gigabit?  Worth a try.

Joe V
(not a Comcast employee, just another paying customer)
Highlighted
Frequent Visitor

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

I selected that but still same thing..
Highlighted
Problem Solver

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

Have you tried different Cat5E cables?  What about the other ports, same thing?  I don't have any other ideas, maybe someone more familiar with that device or your computer model will jump in.

Joe V
(not a Comcast employee, just another paying customer)
Highlighted
Frequent Visitor

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?

I’ve tried different cables (both cat 5e) I switched ports on the XB6 I’ve ordered a new cat 6 cable to see if somehow that helps.
Highlighted
Frequent Visitor

Re: Ethernet Ports on XB6 Modem (TG3482G) Limited to 100 Mbps?


@jav6joev wrote:

Have you tried different Cat5E cables?  What about the other ports, same thing?  I don't have any other ideas, maybe someone more familiar with that device or your computer model will jump in.


I gave in and went to Best Buy and bought a Cat 6 Cable and now I'm having no issues... I am getting 798 Mbps Down which I am more than happy with. Either 20m or even 15m of Cat 5e is too long or Cat 5e is not supported or maybe I got unlucky and had two damaged cables... I was always taught in school cat 5e supports gig up to 90m maybe that isn't the case anymore?