Community Forum

Devices listed multiple times

Highlighted
Regular Contributor

Devices listed multiple times

This morning two of our Apple Watches updated to Watch OS7 and my xFi app told me two new devices connected to the network. They were named **ApleWtch1 and **ApleWtch2. I haven't assigned them to household or guest. I can still see the same two watches as not connected but using Watch OS6. I'm a little confused. This is the first time this happened with the Apple Watches. I've had mine for almost two years and my husband's watch is about a year old. Yesterday I updated both of our iPhones to ios14 and  I only got one notification that a new device connected to the network and the device quickly wenty away before I could see what it was on the app. I went to the website but the right arrow wouldn't work. That sent up a flag for me so I spoke to a tech who told me that is happening for other people. He advised me to just don't do anything. That was yesterday and the mystery device is gone, but the "new" watches are still showing up in the app as conncected with the same watches with the previous watch OS showing as not connected. Something to note is that the same watches with the previous Watch OS hardly ever showed as connected. Now the same watches with the new Watch OS are always connected. I've not checked on the Apple website to see what's new. 
 
Has anyone else experienced this and what if anything did you do? My thought is to just let it all alone and keep an eye on the watches with the old OS. 
Linda
Highlighted
Regular Contributor

I need some help with my xfi app and home network

Friday my husband and I updated our iphones to ios 14.0.1. The following day our Apple Watch Series 4 both updated to Watch os7. Now in the xfi app our iphones and watches keep changing names. It seems that when we leave our home network or reboot our iphones or watches and they reconnect to the network they have a different name and the correct iphones and watches are showing as not connected. I get an email, a text and a notification on my watch each time this happens. It seems that it's a software glitch. Xfiniity said its an Apple glitch and Apple said it's an Xfinity glitch. Whosever glitch it is it needs fixed. We use services that cost us hundreds of dollars each month from Xfinity and buy Apple products that take two years to pay off via Xfinity mobile. Xfinity kept having me reset my router, wait on hold then hung up. Needless to say I'm frustrated. I don't want to reset my Apple devices as it's time consuming and I don't think it will help. I've googled "multiple devices in network" and the search brings me back to Xfinity. I need some help here. My only option for now from Apple is to wait for ios and watch os updates to come out. Does my XB6 router need updated. Does my xFi app need updated? Is somebody working on this so that each time I call for technical support I'm not passed to the other company? 

Linda
Highlighted
New Poster

Re: Devices listed multiple times

My iPhone 7 Plus is showing up twice in connected devices, with different names, and with different phone details (one device shows it's using ios 11, the other says 14, which is accurate). What strikes me as more disturbing is that my wife's iPhone 10XR is showing that it's not connected when it clearly is. Sometimes it doesn't show on the device list at all. That could be happening with an unauthorized device and I'd never know it. Very disturbing, and this new wifi control app is practically useless. All I can do is pause a device, not block it from the network completely. Please, Xfinity, fix this security issue.

Highlighted
Regular Contributor

Re: Devices listed multiple times

That’s very similar to what I see. If I click on device info I see iPhone 13 with iOS 11 and others. It’s ridiculous. To make it worse I can not reply from using Safari browser. If I click on a post in it fills my screen like a word document. I may try chrome and see if that’s any better. XFinity told me the apple software is buggy and Apple told me Xfinity has issues they aren’t aware of yet.

 

EDIT:  It seems better using Chrome.  Right now showing not connected are multiple iphones for myself with various operating systems. The xFi app wants me to assign the new devices that have been showing up since Friday, but I'm not going to in case is causes a problem when the issue is fixed. 

Linda
Highlighted
Regular Contributor

Re: Devices listed multiple times

The xFi app was updated on my iPhone yesterday, but nothing has changed. After it updated, I was asked to review the app in the app store which I did. I gave it one star and then went on the to explain my reasons. I then scrolled thru the other recent reviews and found that most are less than three stars with the majority of reviews being one star reviews. So I'm not the only one having problems with it. It appears that for the last year or so the app has been a problem for some people. For a good while I depended on this app to tell me who was connected to my home network and what websites were being blocked. I checked the app every morning.  No more. One phone tech asked me not to edit any incorrect devices or assign them as he believed that the problem would eventually go away; it happens everytime Apple does a big ios update. The Apple devices that were updated are broadcasting their name to the router and they are currently incorrect. It's a reasonable explanation as the only devices that are giving me duplicate are the iphones and apple watches. My notebook, HP printer, Kindle, sound system, etc never show duplicates. So, I wait and hope the ios and apple watch updates solve the problem. Xfinity doesn't seem to be doing anything and Apple's only route is to reset the devices, which is time consuming so I refused thinking that it wouldn't solve the problem. 

Linda