Community Forum

Cannot Access Xfi at All

Highlighted
New Poster

Cannot Access Xfi at All

Hello, 

 

I've run into an issue with my router and Xfi that (after spending 3 hours on the phone with support) is apparently not even understandable let alone solvable.  All I want to do is some port forwarding on my router. I've done this in the past on 10.0.0.1 and theres been no issue. It seems that at some point xfinity changed it so that you can only access that setting in Xfi now. My issue is that when I try to go to Xfi it tells me "Upgrade for This Experience. To access xFi, you'll need to upgrade your service/equipment." At first I was furios that they would lock a setting that you can access on almost any router ever behind the pay wall of whatever their newest hardware is, but then I became even more furious to discover that I have that hardware already and I still cant access it. When I click the "upgrade now" button on the page that well me I need to upgrade it takes me to a page that tells me I have the "latest equipment." And to top it off I even went to the page that tells you what modems are compatable with xfi

(this page:https://www.xfinity.com/support/articles/broadband-gateways-userguides)

and it says right there that my modem is eligible. (My modem is the DPC3941T) 

 

I have spent hours on trying to fix this, and thats before I spent hours on the phone talking with someone who simply couldn't even comprehend my issue and just forwarded me to a different department that has nothing to do with my issue out of frustration. I've made sure bridge is disabled, I've reset the router entirely. I've soured the internet for anyone who has had the same issue and tried their solutions; nothing. If anyone knows how to fix this, please, end my torture. I just want to port forward.

Highlighted
New Poster

Re: Cannot Access Xfi at All

I am having this same exact issue with no solution.
Highlighted
New Poster

Re: Cannot Access Xfi at All

I was able to fix this issue by going to MyAccount, then the Account Slide down menu and click on Manage or Link Accounts. My old address was still set up as the Preferred Account, so I set my new Address as the preferred account and could now use the XFi App. Hope this helps!