Community Forum

After two weeks of trying -- finally got my HomeKit to work again

Highlighted
New Poster

After two weeks of trying -- finally got my HomeKit to work again

 

I received the Xb7 gateway as part of a upgrade to my system. Prior to that I was using my own modem and router but that's neither here nor there. 

 

Since I wanted to play with the integrated features listed in the Xfinity app, I paied my connected thermostat, ligths, etc. I played with it for about 5 minutes and forgot about it -- quickly realizing that Homekit just works well and quickly with all my devices. 

 

Fast forward about a week or so. Half the time my homekit integration didnt work and I had to launch the app for each of the devices whenever i wanted to use it. For those of you not familiar with Homekit, you basically have a drop dowm menu that allows you to controll all your devices without opening the hue app to turn on a light, then having to switch over to the thermostat app to adjust the temperature, and then hop over to the sonos app to turn down the music.

 

I became frustrated when I could not get things to work after following the advice of a similar post that simply said "yeah they're working on it" --- which I interpreted to mean "we'll get to it when we get to it ST*U." After a bunch of trial an error, this is what I had to do to get things working again: 

 

1) full factory reset of the Xb7 (don't pair the devices to the xfinity app this time around);

2) full factory reset of the devices (setting things up wasn't fun);

3) deleted my "home" from homekit AND deleted the "home" of everyone that shares my household. I didn't realize my wife had set one up too  (I think this is what kept me from registering the devices during previous attempts.); 

4) setup all your devices in whatever app the manufacturer bundles with the device. Skipped adding the devices to homekit until after I had everything labled and working the way I wanted them; 

5) added the devices to a freshly created "home" in homekit and set everything up the way I want ti to work. then and only then I sent out invites to the person sharing my home. 

 

The take away. dont pair your devices to the xb7 if you want to use homekit; and delete all homes form the home before setting things up again. 

 

best of luck.