Community Forum

Access denied to XFi app

Highlighted
New Poster

Access denied to XFi app

I have an xfinity wireless gateway that Comcast had to come and install because I couldn’t get into the xfi app myself on my iPhone. I can login on the My Account app, and on a browser, but it redirects me to the xFi app I login successfully but get an error saying “Access not authorized. You have signed in successfully but you must be an Xfinity user to enjoy this service.” I AM and xfinity user, there is no one else tied to my account, only my one email address/login, and I can login to my account so I’m clearly an xfinity user. I’ve deleted the app and reinstalled, and also cleared my browsing and cache from safari as other posts suggest. HELP!
Highlighted
New Poster

Re: Access denied to XFi app


I’m having a similar issue. I logged into the app and all it says is “you are logged in but we are unable to access your account details. Would you like to try again?” Trying again doesn’t work. Then I tried logging into the website and got a similar error message that we are working on setting up your account. I picked up the internet kit on Monday in preparation for my move today. Makes no sense!
Highlighted
New Poster

Re: Access denied to XFi app

I have exactly the same problem. I need help please
Highlighted
New Poster

Re: Access denied to XFi app

I’ve had the same problem and managed to figure out how to activate my modem. I would like to use the features of the app but... I don’t have access. I read in a different post that you may have to make a new UID because there is something wrong? I haven’t tried it but it may help.
Highlighted
New Poster

Re: Access denied to XFi app

I'm having the same issue. Had a 3rd Gen Gateway installed on the last week of August