Community Forum

A rant about my experience with XFi and Xfinity so far after 4 months

Highlighted
Regular Visitor

A rant about my experience with XFi and Xfinity so far after 4 months

I have been contacting Xfinity Customer Service and Advanced Repair Team pretty much all day trying to resolve the issue with my secondary PC not being recognized on the XFi device list.
1. Yes, the PC has an internet connection.

2. Yes, it's on the same network as the modem

3. Yes, I have turned off IPV6

4. Yes, I have rebooted the modem and the PC multiple times

However, this isn't the only device on my network that is not connected but it is the most important one that I need to be recognized.

 

After 2 support tickets and a "we can't help you", I realized something Xfinity is an absolute atrocity. The representatives clearly have no clue what is happening and there is clearly a lack of communication between internal teams. Why do you ask I say this?

 

1. I was told that devices are only recognized on XFi if they are connected via Wi-Fi. This is false.

My primary PC AND my roommate PC AND my soundbar is connected via Ethernet cable, and they are all recognized on the device list

2. I was told that port forwarding in the conventional method over the default gateway is no longer available.

Excuse me, but if your web app cause more confusion and doesn't work for multiple people it seems on this forum alone. HOW BOUT YOU GIVE US A CHOICES TO USE ONE OR THE OTHER INSTEAD OF DEPRECATING IT COMPLETELY, YA OF 404s!!!!

3. The automated phone system you set up is completely rat nest of a mess, and a rat nest might even be better. It shouldn't have to take me 30 minutes to an hour talk to a representative, cool I know we're in COVID still but if I said "talk to rep" or "talk to support" don't lead me on a Dora and Boots adventure to find useless star mountain. I just wanted to talk to a rep, just put me on hold until one is available.

 

Signed a disgruntle customer

Highlighted
Regular Contributor

Re: A rant about my experience with XFi and Xfinity so far after 4 months

I also do see something that is connected via an ethernet cable. That is my Sony 5.1 sound system, so yeah it's not all the wifi devices you can see there. I started having problems after the recent ios updates. All our devices are clearly connected but show as not connected and we have mulitples of some devices. I hope you get your problem sorted out. 

Linda
Highlighted
Regular Visitor

Re: A rant about my experience with XFi and Xfinity so far after 4 months

To be completely honest, I don't believe they're gonna fix their systems anytime soon just based off the non-compliance and ignorance from the people I've talk to with these question and all the blank and empty threads based off the same or similar issues. 

Best bet for me is buy a 3rd party modem and router from a vendor I trust or switching providers just because the customer service I've received should be below standard for any company.