Community Forum

Xfinity streaming stopped working on Firefox

mgchuch
New Poster

Xfinity streaming stopped working on Firefox

Connecting my laptop to my home wi-fi, I can no longer access TV streaming on Firefox (currently on version 84.0.2). It worked about 2 weeks ago, but since then it gets stuck at the blank page with "xfinity" and the three dots.  The dots just keep spinning and it never connects to the home page to choose a live channel or recorded show.

 

Streaming works fine on Chrome and my Kindle Fire so our service is fine.  However, I would prefer to use Firefox.

 

Grateful to hear any suggestions.  Thank you!

Rustyben
Expert

Re: Xfinity streaming stopped working on Firefox


@mgchuch wrote:

Connecting my laptop to my home wi-fi, I can no longer access TV streaming on Firefox (currently on version 84.0.2). It worked about 2 weeks ago, but since then it gets stuck at the blank page with "xfinity" and the three dots.  The dots just keep spinning and it never connects to the home page to choose a live channel or recorded show.

 

Streaming works fine on Chrome and my Kindle Fire so our service is fine.  However, I would prefer to use Firefox.

 

Grateful to hear any suggestions.  Thank you!


is it up to date? (menu-help-about) downloaded and reinstalled on top of current install? turned off VPN? turned off all extensions? I just loaded and started watching a live HD channel on firefox to test and it works.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
mgchuch
New Poster

Re: Xfinity streaming stopped working on Firefox

Thank you for your suggestions.  Yes - Firefox is latest version, I have no active extensions, and do not use a VPN.  This is so odd, as it has been working fine recently.  Just tried it again (after restarting laptop) and it still hangs on xfinity page with elipses.

 

Guess I will just have to switch to Chrome - as it is working perfectly fine.