Community Forum

NHK World broken on streaming app

Albacete
New Poster

NHK World broken on streaming app

NHK World on the Xfinity Streaming App Beta has stopped working on 2 of my TV's. One is an LG the other is Samsung. It has been working fine on both for several months, although this did happen to me last year as well. At that time the problem eventually disappeared. 

 

On the LG TV I only get a gray colored screen with some digital gibberish flashing along the top of the screen. On the Samsung I get a stuttering version of the last channel I'd watched on the Streaming app.

 

Earlier today I had to delete then reinstall the Streaming app on both TV's. Before deleting the app on the LG I could only receive a static "Error 502: Bad Gateway" message when launching the app. On the Samsung before I deleted the app the picture would go black with a thin white line at the top and freeze when launching the app, requiring me to restart the TV.

 

After reinstalling the app on both TV's as far as I can tell every channel except NHK is working fine.

 

Is there a solution for this?

 

Thanks!

XDawg
Regular Visitor

Re: NHK World broken on streaming app

I was having the same issue on two Samsung QLED TV’s which, after a futile reloading of the app, I resolved by disconnecting power from the outlet. Unfortunately I “power cycle remedy” once a week for other Xfinity Beta connection issues.
Albacete
New Poster

Re: NHK World broken on streaming app

Thanks XDawg, it's good to have a confirmation.

 

Tonight I'm getting a 404 error message page as soon as I launch the app. This app has been in beta for over two years. For me this is an extra I pay Comcast for and this issue never being truly resolved is making me question my subscription to the Stream service.