Community Forum

Error TVAPP-00101: Initial login on Roku to Streaming app

JimWiE
New Poster

Error TVAPP-00101: Initial login on Roku to Streaming app

I've just moved into a new place.  I have Xfinity internet and went with streaming cable.  I have a TCL TV with Roku.  I have the network gateway working.  The internet service is great and coverage is strong.  Signal to the set lists out as "Excellent".  Neflix, Prime, Disney+, Youtube, you name it all stream perfectly.  Now to the problem.

 

I downloaded the app to the TV.  I follow the instructions to sign in, go to the website, punch in the code.  My browser on my laptop tell me success.  My TV tells me, "This device can only access Xfinity stream on your in-home Xfinity Wifi. ...."  And I see Error:  TVAPP-00101.  I contacted customer service and they were of no help.

 

I don't know if this complicates things but we have 2 accounts at 2 separate addresses.  The two accounts are linked.  The other account was the primary account.  That account is internet only.  The new account that I'm attempting to stream on is internet and tv (no set top box).  I can stream on by laptop browser.  I switched the new account to primary and tried it again last night.  No joy.

 

Am I doing something wrong with the initialization?  I can't seem to make a choice when it comes to activating the service as to which account it is.  Any ideas?  I see a lot of threads here and read through a bunch of them.  Maybe they pertain, but I don't even know if I'm logging in correctly at this point.  Any help would be greatly appreciated.

Rustyben
Expert

Re: Error TVAPP-00101: Initial login on Roku to Streaming app


@JimWiE wrote:

I've just moved into a new place.  I have Xfinity internet and went with streaming cable.  I have a TCL TV with Roku.  I have the network gateway working.  The internet service is great and coverage is strong.  Signal to the set lists out as "Excellent".  Neflix, Prime, Disney+, Youtube, you name it all stream perfectly.  Now to the problem.

 

I downloaded the app to the TV.  I follow the instructions to sign in, go to the website, punch in the code.  My browser on my laptop tell me success.  My TV tells me, "This device can only access Xfinity stream on your in-home Xfinity Wifi. ...."  And I see Error:  TVAPP-00101.  I contacted customer service and they were of no help.

 

I don't know if this complicates things but we have 2 accounts at 2 separate addresses.  The two accounts are linked.  The other account was the primary account.  That account is internet only.  The new account that I'm attempting to stream on is internet and tv (no set top box).  I can stream on by laptop browser.  I switched the new account to primary and tried it again last night.  No joy.

 

Am I doing something wrong with the initialization?  I can't seem to make a choice when it comes to activating the service as to which account it is.  Any ideas?  I see a lot of threads here and read through a bunch of them.  Maybe they pertain, but I don't even know if I'm logging in correctly at this point.  Any help would be greatly appreciated.


does it work with your smart phone/tablet?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
JimWiE
New Poster

Re: Error TVAPP-00101: Initial login on Roku to Streaming app

It definitely worked on my laptop.  However, I wanted to report that it started working 3 days ago.  The same day I posted the op.  I think I had to do the unplugging of the gateway route in order to get past this.  My painters unplugged by gateway while I was at work and that night, when I checked again, boom, it connected and I've been good ever since.

 

This process was more complicated than it should have been, but the service is pretty good.