Community Forum

Problem with MMS since update to android pie

Highlighted
Contributor

Re: Problem with MMS since update to android pie

Xfinity told me this was supposed to be addressed by a samsung update that was supposed to be out on march 18th. Guess not.
Highlighted
Frequent Visitor

Re: Problem with MMS since update to android pie

I have the same issue.  I sure would like to see this resolved, too.

Highlighted
Contributor

Re: Problem with MMS since update to android pie

I'd be happy if the wifi would automatically turn off automatically and back on after sending, I keep forgetting to turn it back on and use more data than usual.

 

Frequent Visitor

Re: Problem with MMS since update to android pie

I'm having the same problem. Spent 2 hours on the phone with Xfinity Mobile. Customer service reps were nice, but I was told to turn Mobile Data on. Just turned it off, and things started working again. They also said it was a Samsung issue, and Samsung was going to have an update in April. We'll see what won't work then.🤔

I have a Galaxy S8, and using the un-installable app that came with the phone.  I tried it with Google's Messages, and it had the same problem. I'll try reinstalling Googles again and see if it works.

At the moment I'm more concerned with COVID-19, and thankful that life is good. I have a friend in her 30's who caught it, and is thankfully recovering. She said you don't want to find out what it's like!

I'm heading to 72 in July, and the parts don't work the way they use to. 

I can live with a semi-operational phone, wash my hands lots, and stop myself from touching my face unless I'm close to my shower!😷😎

Everyone stay well.

Highlighted
Contributor

Re: Problem with MMS since update to android pie

I have a Samsung Note10 and I can't believe there is no way to have the phone realize the wifi has been toggled off and turn it back on.

I hear you on that. I had open heart surgery 8 months ago and had lung issues afterward. Don't want to go THERE again!

 

#StaySafeStayHome

Highlighted
Contributor

Re: Problem with MMS since update to android pie

As suggested from a Reddit member, I downloaded Macrodroid. It has a ton of options on an "if this...then that" platform.
It was simple to do an if I turn my wifi off (to send a pic or mms), it turns it back on. You can't dally, it turns it back on within seconds. Not as good as it turning off and back on automatically but better than forgetting it's on and using too much data...
Highlighted
Frequent Visitor

Re: Problem with MMS since update to android pie

First - this is NOT an Xfinity problem.  I had (yes, "had" - we'll get to that) the problem and it was an issue on any wifi connection - home, work (not Xfinity), my brother's house (not Xfinity)...  In addition,  I have a Samsung S9+ and my wife has an S9.  We got them at the same time.  Hers has never had this problem.  We both use Messages from Google LLC instead of Messages from Samsung.  Oddly, we have different versions listed - hers is newer - so I was trying to get that one to load on my phone, with no luck.  However, uninstall and reinstall of the application resolved my issue.  I had gone through all settings and found no differences, but I may have missed something.  I also had the problem with Messages from Samsung and now no longer, so reinstalling the Google app changed something that affected both apps.

 

For those interested, here are the versions.  I'm going to contact Google about that.  

5.4.087 Roper_RC15  1/29/2020  mine
5.7.097 Unicorn_RC09  3/25/2020  hers

Highlighted
Contributor

Re: Problem with MMS since update to android pie

I have the same version as your wife. I'm not able to send pics without turning off wifi with either it or the Samsung messaging app.

I didn't mean that it was an Xfinity internet problem...I meant an Xfinity mobile problem.

When I got my phone, they sent me a new SIM card. They were unable to transfer my # to the new SIM for some reason so they told me to put the old SIM in the new phone. That meant they had 2 SIM cards registered to me so I have 2 lines listed on my account but I only have one phone. I've been trying to get that straightened out for over a month. Every time I call, they escalate me to a higher tier, I'm assured the issue will be fixed and they'll follow up with it and call me back to verify that. No one calls me back, I call back and we start the whole thing again. I don't have a whole lot of faith when Xfinity says "it's not us, it's Samsung!" 

 

Highlighted
Frequent Visitor

Re: Problem with MMS since update to android pie

Not that, either. A web search shows people with several carriers with the same issue - T-mobile, Cricket... Try uninstall/reinstall? Can't hurt.
Highlighted
Contributor

Re: Problem with MMS since update to android pie

MMS seemed to be working fine for me this past weekend (after months of same problem).  I didn't notice any updates, so not sure if just a fluke or something was fixed.  But I didn't have to turn WiFi off to send mms messages.  Will continue to monitor, but fingers crossed.  (Samsung S10+)

Highlighted
Contributor

Re: Problem with MMS since update to android pie

All Samsung devices though, correct? When I chatted with Samsung, they acted like they had no idea what i was referring to. I highly doubt that's true.

 

 

Highlighted
Contributor

Re: Problem with MMS since update to android pie

I just tried to send myself a pic with wifi on and no luck. I did have a pic go through on both google messaging and Samsung messaging the other night. I got all excited but the next morning, I was back to it not working again....

Highlighted
Frequent Visitor

Re: Problem with MMS since update to android pie

And apparently, mine has stopped working again, too.  Frustrating issue. 

Highlighted
Contributor

Re: Problem with MMS since update to android pie

Too funny bc I just popped on here to say that I just sent a couple pics without turning wifi off. We'll see how long it lasts.
Highlighted
Contributor

Re: Problem with MMS since update to android pie

Currently working  but don't know how long that will last. Seems pretty sporadic and very slow, about 10 seconds to send a picture. Turning the wifi off sends within a couple seconds and the Macrodroid turns it back on pretty much instantaneously so we'll see.

Highlighted
Contributor

Re: Problem with MMS since update to android pie

It's been working fine for me for about a week now, but agree that it is a bit slower than expected.  As long as it's working with any manual intervention, I'm happy!  Fingers crossed.

Highlighted
New Poster

Re: Problem with MMS since update to android pie

I don't know why everyone is saying this is a Samsung issue. My hubby just got a Moto G7 Power and it has the same problem except it won't send/receive with wifi on or off, only with data on. Also, doesn't like regular group messages either.
Highlighted
New Poster

Re: Problem with MMS since update to android pie

Just thought I'd add a bit here as a new Xfinity Mobile customer. My wife and I are having this issue. I use the texting app Textra which has a setting for this exact reason that switches off WiFi to send/receive an MMS and then turns it back on. Very handy.
Highlighted
Contributor

Re: Problem with MMS since update to android pie

Isn't that funny....Textra didn't work for me when I tried it. I ended up installing macroDroid which will automatically turn my wifi back on if I have to turn it off to send a mms. For the most part now, I don't have to turn off the wifi to send anything, whether that was an update on Samsung's, Android's or Xfinity's part I don't know. Once in a blue moon I'll get something that doesn't go through. Odd. For what you pay now for a phone and service, the things should perform flawlessly.

 

Highlighted
Frequent Visitor

Re: Problem with MMS since update to android pie

My Samsung Galaxy A50 is finally able to send MMS without turning off the wifi.

Highlighted
Regular Contributor

Re: Problem with MMS since update to android pie

Nice job describing symptoms and workaround, people!   🙂     Trying different messaging apps is a great way to test/mitigate/workaround these sorts of android MMS/texting problems.    Remember to try the default google "blue icon" messaging app too as well as the manufacturer default.   Try that blue default google messaging app especially when the manufacturer default messaging app keeps tanking...