Community Forum

Unique On Demand Signal Problem

Contributor

Unique On Demand Signal Problem

A couple of days ago a unique (I think) OnDemand problem began. This issue pertains only to the OnDemand via internet and using my main laptop. OnDemand via cable box using TV is fine. The OnDemand signal is breaking up, pixilating, etc. Basically unwatchable. Audio is fine. Changed ethernet cord and also tried wireless--same problem. But signal is fine using secondary laptop and smart phone. So you would assume problem is with laptop? But signal is otherwise fine at all other web sites viewing videos. Also fine viewing Amazon Prime movies, etc. So appears isolated to Comcast OnDemand and on this particular laptop.  One would assume that if I could watch other videos and also Amazon Prime streaming video, I could also get a good signal from Comcast OnDemand. Any thoughts on this problem?

PS-Watching live TV on Comcast via internet on same laptop is fine. So problem is with OnDemand only!

New Poster

Re: Unique On Demand Signal Problem

I am having this same issue  starting this morning  ..

Last night it was  normal picture ..

Now the  picture is pixalated and unwatchable ..

live channels are  perfect stream ..

It is ONLY   the  On-Demand  content   and shows that are having this issue 

New Poster

Re: Unique On Demand Signal Problem

The only way I could solve this issue is completely remove Google Chrome .

Install an older version .. 

The August update  is the  installation I chose .

All On Demand  content  now plays  flawlessly  . 

Contributor

Re: Unique On Demand Signal Problem

Seems like it is definitely a Chrome issue. Works fine using MS Edge. Very odd.....

Diamond Problem Solver

Re: Unique On Demand Signal Problem


https://forums.xfinity.com/t5/XFINITY-Stream-Website/streaming-online-shows-cut-up/td-p/3277104

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Silver Problem Solver

Re: Unique On Demand Signal Problem

I installed the newest version of Chrome and my streaming seems to be working but I'll have to do more testing.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Contributor

Re: Unique On Demand Signal Problem

What is version number?

Silver Problem Solver

Re: Unique On Demand Signal Problem


@pbr1912 wrote:

What is version number?


78.0.3904.87


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Contributor

Re: Unique On Demand Signal Problem

I still have problem unless hardware acceleration is turned off.

New Poster

Re: Unique On Demand Signal Problem

Your signal problem isn't unique.  I need help as I am uncertain about uninstalling Google as I don't know what will happen to what I've taken weeks to setup.  Without proof I do believe it is a Google issue.  (My headset doesn't work anymore because it claims my microphone isn't setup.  This started with a Google update.)  I don't have a microphone.  Any reassurance I won't regret uninstalling Google would be appreciated.  Xfinity, reach out to Google!