Community Forum

Streaming issues from the Xfinity.com but NOT the iOS apps

Frequent Visitor

Streaming issues from the Xfinity.com but NOT the iOS apps

I have a new router from Wifi, a MacBook Air, and an Apple TV.  When I stream the xfinity go channels, the picture starts out sometimes very clear, but then loses quality and gets "fuzzy".  I have tried everything but nothing corrects it.  I also have an iPhone and an iPad and when I use the Xfinity Stream app it's PERFECT!  I really want to try and get this figured out because football season is coming and that's how I watch the games.  Please HELP.  

New Poster

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

The fuzz you speak of is likely a change in MPEG compression due to possible bandwidth limitations on your Macbook.  For example - if you're moving a lot of data over your WiFi connection on the Macbook the bit rate may vary on the video you're watching based on other tasks your Mac is doing.  If you're say downloading a huge file and its sapping all of your downstream bandwidth while you're also trying to stream the stream app may be changing the MPEG level to avoid stuttering.  It's similar to watching videos on YouTube in "auto" mode where you can do say 4K video over a very fast connection and you get 360p over a slower connection.  Keep in mind that the connection itself might be very fast but the Mac might be doing a lot with that connection outside of the video stream

Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

I don't think it is the device, i.e. MacAir problem.  I have both a MacAir book and an IMAC.  Both purchased within the last month, with all of the higher end processing features. When I am traveling, both do this.  I have noticed this recently on a PC as well.  This did not used to happen.  I am wondering if Comcast/Xfinity is determining IP address and changing the qualtiy.  This happens with TVGO channels as well as non HD channels as well. 

 

Is there a fix?

Expert

Re: Streaming issues from the Xfinity.com but NOT the iOS apps


@mds-mn wrote:

I don't think it is the device, i.e. MacAir problem.  I have both a MacAir book and an IMAC.  Both purchased within the last month, with all of the higher end processing features. When I am traveling, both do this.  I have noticed this recently on a PC as well.  This did not used to happen.  I am wondering if Comcast/Xfinity is determining IP address and changing the qualtiy.  This happens with TVGO channels as well as non HD channels as well. 

 

Is there a fix?


are both on the same home wifi when the problem happens? 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

None of them are connected simultaneously.  I tried, them separately, hoping? that maybe it was just a device issue.  So the answer is, no,  not on the network simultaneously. 

Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

 Sorry, I missed the part about being on my home wife.  I travel alot, so this happened when I am not on my home network.  I am now back home, and have not had time to test it out here.  I usually watch the shows on my TV, not my devices through the internet.

Expert

Re: Streaming issues from the Xfinity.com but NOT the iOS apps


@mds-mn wrote:

 Sorry, I missed the part about being on my home wife.  I travel alot, so this happened when I am not on my home network.  I am now back home, and have not had time to test it out here.  I usually watch the shows on my TV, not my devices through the internet.


when away from home using the TVgo channels and TVgo on-demand the data carrier may not allow HD quality on their data network. using an encrypted VPN when away from the home may mask the type of data and cause it not to be throttled. Xfinity does not have any outsife of the home downgrading. If you use xfinity cell service they offer a montly fee to allow use of HD video.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

MMM, I dk what to say.  This does not happen on my IPAD pro 9.7 inch where the streaming app is available and I use it on this network.  The Mac Air is 13 inches, but neither the MacAir nor the IMAC have an Xfinity streaming app avaiable, so it is through the browser.  The IPAD pro's picture is never "Fuzzy". I am not sure that "Fuzzy" is the right description, because you can see the edge of the square pixels if you look closely.  but the picture does look fuzzy.  With my PC, it was not happening 6 months ago, and probably not 3 months ago.

 

Also note,  this does not happen when I am streaming an Amazon Prime video (Very clear picture).  Only through the Xfinity website.  Also.  I first noticed it on the TVGO channels, but then tried the non HD channels at the lower end of the channel number, list.  I do not use a VPN. 

 

I have tried to problemsolve a variety of parameters, including whether the adobe flash was a factor.  Sometimes the browser wants to be reloaded, to apply the changes ( I assume that is allowing adobe flash), but it works without the reload, sometimes dispalying a better picture longer, but not permanently.  That means, that the it can display it. I was worried, that it might be connection, but others are reporting it. Also, a speed test reveals a 50Mps download speed.  I hope this information is helpful.

Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

One additional note.  I stream the Amazon prime video also through the browser, not the streaming app.

Expert

Re: Streaming issues from the Xfinity.com but NOT the iOS apps


@mds-mn wrote:

One additional note.  I stream the Amazon prime video also through the browser, not the streaming app.


when using your home wifi (ipad?) the signal will be as good as the data connection. from your previous post it seemed you were having trouble "fuzzy" when outside the home. are you speaking of TVgo outside the home or numbered channels (linear) while in the home connected to your home wifi?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

All of the activity is outside of my home wifi system.  At home, I use my TV service.  When I log onto the xfinity website, it gives me the option of all of my channels as well as the TVGO channels.  When I referred to the IPAD Pro,  that also was not on my home WiFI network.  The IPAD Pro image outside of the home is just fine.  It is only when using a desktop and logging on through the web browser is the image poor.  Again, this is not the case with Amazon Prime video streaming through the web browser. 

New Poster

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

I don't have problems with fuzzy picture but when I use my PC on my home network with over 50 mbps speeds it takes forever to load & navigate. Then when I finally select something to watch it will play for 10-45 minutes then the page will reload. & it will do that over & over again. Eventually it will just stop & not reload. Very annoying. The app on my phone works perfectly whether on wifi or my at&t service. Only have this issue with Xfinity streaming & no other streaming website. It will probably just continue to be a problem til they make an app for PC.
Frequent Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

Thanks for all the replies, it seems it's just not me.  My wifi is about 70mpps. This thing with the fuzzy picture on the macbook using the xfinity.com streaming site is the only place that is an issue.  When I use my iPad or iPhone via the streaming app all is fine.  I just wonder if xfinity/comcast is causing this trying to force people to submit to cable.  I did not used to do this 3 months ago.  I'm getting a bit frustrated.  

Frequent Visitor

Re: Streaming issues from the Xfinity.com but NOT the iOS apps

The odd thing is too is when the show takes a break and a commercial of some kind comes on, it's really clear and sharp, and then when the programing starts again, back comes the fuzzies.  I think it's definately the signal on the cable coming into the router.