Community Forum

How to turn off autoplay when streaming from the website using a browser?

Regular Contributor

How to turn off autoplay when streaming from the website using a browser?

For some reason, xfiniity has started automatically playing the next video when the one I was watching has ended. This is a problem when I fall asleep. It used to finish playing the video and then quit. Now it plays and plays and plays for hours until I wake up and figure out it's still going.

 

I did not do anything to start this autoplay. It seems to be something changed on the xfinity website.

 

How can I turn this autoplay off?

 

Note: I usually stream xfinity using either Safari v11.1.2 or Chrome v77.0.3865.120. The shows I'm streaming are from Saved > Favorites. I do not have a DVR. This is all xfinity website based.

Regular Contributor

Re: How to turn off autoplay when streaming from the website using a browser?

I found the option to turn it off! I was looking all through the settings while playing the video when I remembered that there are other settings at the top of the page. Clicked on that wheel, selected playback preferences, and voila! There was the toggle switch to turn autoplay off. Too bad I didn't think of this before starting this thread, but at least it's resolved.

New Poster

Re: How to turn off autoplay when streaming from the website using a browser?

I can't find the setting to turn off Autoplay.  Anyone can help?

 

Expert

Re: How to turn off autoplay when streaming from the website using a browser?


@shack2 wrote:

I can't find the setting to turn off Autoplay.  Anyone can help?


https://www.xfinity.com/stream/settings/playback-preferences  it is in your 'gear' settings, playback preferences. turn off autoplay next episode.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!