Community Forum

Can't add 3rd TV to X1 using the Beta app

Highlighted
New Poster

Can't add 3rd TV to X1 using the Beta app

I have the gigabit router, and all New Samsung TV's.  I have loaded and am using the Beta Streaming app on 2  of the TV's.  My 3rd TV just shows a large question mark and various web pages to look at for info to learn more about th Beta Stream.  I am using wifi via the Xfinity pods and I have strong signals.  I can get YouTube TV (which I am cancelling) and various other channels.  I just can't get the streaming app on my TV to open.

Any help is greatly apperciated! 

Highlighted
Expert

Re: Can't add 3rd TV to X1 using the Beta app


@renpah wrote:

I have the gigabit router, and all New Samsung TV's.  I have loaded and am using the Beta Streaming app on 2  of the TV's.  My 3rd TV just shows a large question mark and various web pages to look at for info to learn more about th Beta Stream.  I am using wifi via the Xfinity pods and I have strong signals.  I can get YouTube TV (which I am cancelling) and various other channels.  I just can't get the streaming app on my TV to open.

Any help is greatly apperciated! 


did you download the stream beta app from your TV's 'store'? that is the only supported TV app available. else you must use a Roku or chromecast with a PC.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!