Community Forum

Xfinity stream app on smart TvS

Highlighted
New Poster

Xfinity stream app on smart TvS

App is not loading all my channels into the guide. I have deleted and reinstalled it multiple times to try resolving this issue. I have now been on the phone for two hours trying to get this fixed. We just got this service installed yesterday and the technician did not check to make sure our stream app was working before leaving. I am extremely frustrated at this point. I searched on this forum and it says that my entitlements need refreshed on Comcast’s end. But this has not need done yet.
Highlighted
Expert

Re: Xfinity stream app on smart TvS


@Nlm273jacobs wrote:
App is not loading all my channels into the guide. I have deleted and reinstalled it multiple times to try resolving this issue. I have now been on the phone for two hours trying to get this fixed. We just got this service installed yesterday and the technician did not check to make sure our stream app was working before leaving. I am extremely frustrated at this point. I searched on this forum and it says that my entitlements need refreshed on Comcast’s end. But this has not need done yet.

could you give a few examples? not loading does not state what the problem is about. are you speaking of the guide? watching live channels in home? tvgo channels? on-demand programming? watching recordings?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Xfinity stream app on smart TvS


@Nlm273jacobs wrote:
App is not loading all my channels into the guide. I have deleted and reinstalled it multiple times to try resolving this issue. I have now been on the phone for two hours trying to get this fixed. We just got this service installed yesterday and the technician did not check to make sure our stream app was working before leaving. I am extremely frustrated at this point. I searched on this forum and it says that my entitlements need refreshed on Comcast’s end. But this has not need done yet.

I'm curerntly having the same issue.  Multiple calls to Comcast/Xfinity have been fruitless so far,   though one of the agents mentioned that mine was one of 400 similar incidents "in the queue".  Don't know what to make of that other than it seems to be a known issue that they are hopefully trying to resolve universally.  I'll let you know if I get some resolution.  Please post here if you find a solution as well.

Frequent Visitor

Re: Xfinity stream app on smart TvS

So I finally found a super-helpful rep who was able to solve the problem.  It was a backend issue wherein my userID no longer linked properly making the system think I had no access to TV channels.  The rep had to "repackage" the account into the same package we already had.  Essentially a hard forced-refresh it sounds like.  Hope this helps others.