Community Forum

Xfinity Beta app stuck on initializing

Highlighted
New Poster

Xfinity Beta app stuck on initializing

All of a sudden, the App is not working on either of our Roku's. The screen is stuck on initializing. We've tried deleting the app and reloading, with no success.

Highlighted
Expert

Re: Xfinity Beta app stuck on initializing


@mlineweber wrote:

All of a sudden, the App is not working on either of our Roku's. The screen is stuck on initializing. We've tried deleting the app and reloading, with no success.


first, try a power down of your modem/gateway (unplug for 3+ minutes and then plug back in. after the LEDs show bootup complete try again.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

This was happening to me on my Roku. I solved it by re-starting the Roku. Start with options (the gear symbol in the upper right corner of the screen), and look around until you see the re-start option. It only takes a minute or so to finish rebooting.  There were some other apps that loaded but didn't log in, this fixed them all.
I'm not sure if this was the cause, but the problem began after a power surge in our house.

Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

Okay, new Roku TV user and the Xfinity Beta app is stuck on 'Initiailizing". I've tried all the suggestions:

- Uninstall the app

- Reset the cable modem

- Reboot the TV

- Re-install the app

It made no difference, even after two attempts to do this.

 

I see some suggestions to logout of the app - this is NOT possible since I never get a chance to login. 

 

My other apps (HBO, Disney+), see to be streaming perfectly easily.

 

I looked at the settings/network and it says the TV is on the 2.4ghz wi-fi band, channel 8. Bandwidth shows as Excellent (16mbps). 

 

1. This appears to be an on-going problem that comes and goes. Am I right on this?

2. Any new suggestions on getting it to work?

@ComcastJK 

Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

Okay fixed! I kept turning the TV on/off, but then I remembered that turning off the TV with the remote does not really turn the TV off - it just turns the screen off and it goes to standby. 

 

So I unplugged the TV, counted slowly to 10 and replugged in the TV. And voila - I got into the app login screen and I'm off streaming!

Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

Thanks for your posts, especially the follow up post.  We've had the same issue for three days.  Our Xfinity beta app that's worked for months with our Roku devices suddenly got stuck on initializing...both TVs with separate Rokus (of course).  Before coming to this forum, I unplugged both the Rokus and the TVs, let them stay powered off for 60 seconds.  Still nothing.  The app for our iPhones still streams fine; it's just the beta app.

 

Second thought:  Why is it still a beta app?  Can't Xfinity do better to compete with YouTube TV (which I had and liked for 2.5 years until they increased their price)?  Wishing I hadn't left YouTubeTV.

Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

Thank you! That worked for me!

Highlighted
Regular Visitor

Re: Xfinity Beta app stuck on initializing

I have the same frustration regarding the streaming app.  I've had the app for two years and this is not the first time it has gone down for days.

I also have the same second thought as you.  Beta, really??

Highlighted
Expert

Re: Xfinity Beta app stuck on initializing


@MaryAnnKRN wrote:

I have the same frustration regarding the streaming app.  I've had the app for two years and this is not the first time it has gone down for days.

I also have the same second thought as you.  Beta, really??


moved entire thread to stream app area of the forum.

 

remove the xfinity channel from the Roku device. then power unplug the Roku from all cables for 2-3 minutes and reconnect. install the xfinity stream beta app and sign in. be sure to carefully approve the terms and conditions. youmust be on your own home wifi using comcast's DNS servers. If you are still having problems, please describe the exact issues you are having. how far do you get into the menu? error messages shown?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Xfinity Beta app stuck on initializing

 I have been using the app for two years. It stays automatically signed in. But ever since Wednesday, March 25 it will not even open on the TV. It starts to initialize and then I get an error message that says it’s unable to connect to the server and to check my network connections. My network connections are fine I can use all the other apps on the TV.  

Highlighted
Expert

Re: Xfinity Beta app stuck on initializing


@MaryAnnKRN wrote:

 I have been using the app for two years. It stays automatically signed in. But ever since Wednesday, March 25 it will not even open on the TV. It starts to initialize and then I get an error message that says it’s unable to connect to the server and to check my network connections. My network connections are fine I can use all the other apps on the TV.  


didyou recently move? change your gateway/modem?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Xfinity Beta app stuck on initializing

No nothing like that. Modem hasn’t been moved. It has been rebooted. Everything else in the house and on the TV works. It’s just the Xfinity App that doesn’t work.
Highlighted
Expert

Re: Xfinity Beta app stuck on initializing


@MaryAnnKRN wrote:
No nothing like that. Modem hasn’t been moved. It has been rebooted. Everything else in the house and on the TV works. It’s just the Xfinity App that doesn’t work.

did you try streaming with a smart phone/tablet?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Xfinity Beta app stuck on initializing

I just tried the Xfinity streaming app on my iPhone. It starts streaming and then abruptly stops. I tried closing the app and even tried different live channels but keeps stopping. All the more reason that I think it’s their app and not my TV or network.
Highlighted
Expert

Re: Xfinity Beta app stuck on initializing


@MaryAnnKRN wrote:
I just tried the Xfinity streaming app on my iPhone. It starts streaming and then abruptly stops. I tried closing the app and even tried different live channels but keeps stopping. All the more reason that I think it’s their app and not my TV or network.

have you tried powering down your phone for a few minutes then trying again? (this is not just locking the phone). tried another phone? moved closer to the router?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Xfinity Beta app stuck on initializing

The phone is not the issue.  The original issue was that I couldn't use the Xfinity APP on my Samsung TV!  We had a power outage two days ago and now the APP works.  I was on the phone with Comcast for over an hour trying to power everything down and reboot and delete this and reinstall that and whatever.  Somehow, it's fixed now.  Good day.

Highlighted
New Poster

Re: Xfinity Beta app stuck on initializing

I had been having the same problems and nothing seemed to work for me until a Modem reset signal was sent from Comcast. I believe you can do it through the account management services online or just call the customer service number and do it through the automated service.

 

Hope this helps.

Highlighted
Silver Problem Solver

Re: Xfinity Beta app stuck on initializing

You don't need to send a reset signal. Just pull the power cord for a few seconds, plug it in, then give it a few minutes to reconnect.