Community Forum

Version 3.6.1 Xfinity Streaming app on Roku TV not working

Highlighted
Regular Visitor

Version 3.6.1 Xfinity Streaming app on Roku TV not working

My Roku TV Xfinity Streaming app worked perfectly until a couple days ago when it updated to version 3.6.1 dated 9/11/2019 and bricked it.  Now the app hesitates on the Splash Xfinity screen & subsequently locks with Initializing... at the bottom.

Finally, I get a message:
Sorry something went wrong.  Please try again later.

                                                                                                                 (Error)

I've been through technical support on both Xfinity and Roku and only received mutual finger pointing from both.

  Any help on the way?

Expert

Re: Version 3.6.1 Xfinity Streaming app on Roku TV not working


@sonomateacher wrote:

My Roku TV Xfinity Streaming app worked perfectly until a couple days ago when it updated to version 3.6.1 dated 9/11/2019 and bricked it.  Now the app hesitates on the Splash Xfinity screen & subsequently locks with Initializing... at the bottom.

Finally, I get a message:
Sorry something went wrong.  Please try again later.

                                                                                                                 (Error)

I've been through technical support on both Xfinity and Roku and only received mutual finger pointing from both.

  Any help on the way?


on the roku highlight the xfinity channel then press the roku remote * (star) button and delete the channel. unplug all cables from the roku for 30 seconds or so then plug back in and add the channel back to the roku and re-authorize. working?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Version 3.6.1 Xfinity Streaming app on Roku TV not working

Thanks for the reply.  I did what you described twice; once with technical support with Xfinity & then once with Roku - to no avail.  

The Roku tech support said it was an Xfinity problem since all of my other Roku apps worked fine and Roku just provides the platform for the apps.  The Xfinity tech support said that it was a Roku issue, and did not question whether it might be an Xfinity app issue.

I know that the previous version of the Xfinity app worked perfectly, so it is the upgraded app that is the issue.  Would be happy to roll back if I could figure out how. 

The Xfinity Windows app works fine, so I am successfully connecting to Xfinity - just not through the new Roku Xfinity Streaming app.