Community Forum

Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

Highlighted
Frequent Visitor

Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

I hope someone can please please help me. I am having to repeatedly having to uninstall/reinstall/re-authorize/re-activate Xfinity Streaming App on Roku TV. Let me clarify.

 

My home setup: I subscribe to a 200+ channel Xfinity TV packagre and Xfinity Blast Internet. I provide my own cable modem and wireless router. I have one TV connected to a Xfinity DVR box. I have 4 other TV's using Roku devices with the Xfinty Streaming BETA app.

 

History: Until about a month ago, Xfintiy Streaming was working fine on all 4 Roku devices and life was great.  However, during the last month, things have gone down hill greatly.

 

The current common scenario: Of the morning, I try to watch Xfinity on a Roku device (usually my TCL TV with built in Roku). When I click on the Xfinity Streaming app, it briefly sits at a blank red screen, then I'm bumped back to the main Roku screen. No matter how many times I then try again, I merely see a red screen and am bumped back to the main Roku screen. So, I then unistall and resinstall and re-authorize the Xfinity Streaming app on the Roku TV. All works beautifully and smoothly. So, I then visit all of the other Roky devices and re-authorize them and they also work smoothly. All is great until the next morning when Xfinity Streaming is no longer working again. . Currently, I am having to uninstall/reinstall/re-authorize/re-activate Xfinity Streaming App on Roku TV nearly every single morning. It's important to clarify now that when Xfintiy is refusing to work, I can still readily/easily/promptly use other streaming services on the Roku such as Hulu/Netflix/YouTube .... so this is clearly not an internet connectivity issue. 

 

What I've tried: Before uninstalling/reinstalling/re-authorizing/re-activating Xfinity Streaming App on Roku TV, I've tried merely rebooting the modem and router. I've tried this more than once but it didn't help at all. I've even totally replaced my router recently, but that didn't help either.

 

My guess: This 'seems' to perhaps be an issue with the app losing it's authorization/activation?????  Again, after I reinstall/re-authorize the app, it works perfectly fine for about 24 hours.

Highlighted
New Poster

Re: Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

Same issue here on two Roku TVs. Did you ever find a solution?
Highlighted
New Poster

Re: Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

I am having the same problem. This happens freqently and is so annoying. Does anyone have an answer to this?

Highlighted
New Poster

Re: Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

Ditto.. I have my own my modem and it is registered correctly with Comcast.

I recently installed an eero and turned off the wireless on the modem I wonder if there is something going on there. I suspect it, as this issue happended shortly after switching..

Very annoying!
Highlighted
New Poster

Re: Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

Why hasn’t this issue been addressed? It’s happening to me also! I’m not impressed with this site, unfortunately there are no other options? I hate this company. I don’t know a single soul that hasn’t had issues with one problem or another using Xfinity?
We shall see if our Authorisation problems are addressed???
Highlighted
New Poster

Re: Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV

I have the same problem