Community Forum

Re: Xfinity Steam Beta on Roku - TVAPP-00101

Highlighted
New Poster

Re: Xfinity Steam Beta on Roku - TVAPP-00101

Many are having this same issue. I am having this issue and it happens intermittently.  The base of this issue comes from Comcast/Xfinity NOT FINISHING the Roku Streaming App and leaving it in a Beta stage.  The application should have been developed and tested thoroughly and moved to a production release.  This Beta is *buggy* at best.  If Xfinity DOES NOT want to support Roku properly they should drop this effort and just enforce individuals to utilize their set-top device(s).  There is no way this device should have as many issues as it has with it connection/synchronization with Comcast/Xfinity accounts.    I noticed that making sure the Roku device is updated and doing a hard-reboot MAY sometimes clear this issue as is generally shows up once there is a Roku system/firmware update.  The firmware update is not in sync with Comcast where it should've been tested with Comcast/Xfinity.   Xfinity fix YOUR product/service please. Thank you.

Highlighted
Expert

Re: Xfinity Steam Beta on Roku - TVAPP-00101


@hurricane9que wrote:

Many are having this same issue. I am having this issue and it happens intermittently.  The base of this issue comes from Comcast/Xfinity NOT FINISHING the Roku Streaming App and leaving it in a Beta stage.  The application should have been developed and tested thoroughly and moved to a production release.  This Beta is *buggy* at best.  If Xfinity DOES NOT want to support Roku properly they should drop this effort and just enforce individuals to utilize their set-top device(s).  There is no way this device should have as many issues as it has with it connection/synchronization with Comcast/Xfinity accounts.    I noticed that making sure the Roku device is updated and doing a hard-reboot MAY sometimes clear this issue as is generally shows up once there is a Roku system/firmware update.  The firmware update is not in sync with Comcast where it should've been tested with Comcast/Xfinity.   Xfinity fix YOUR product/service please. Thank you.


moved your off-topic reply to a separate thread. fwiw i have 5 roku and almost no issues until I changed out a gateway (had to uninstall and reinstall to make 2 of the 5 work again).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!