Community Forum

Problem With Xfinity Stream App

Highlighted
New Poster

Problem With Xfinity Stream App

My Xfinity works fine on my TV but the Xfinity Stream apps (Version 5.13.1.1502) on both my iPhone 8 Plus and my iPad Pro (both are iOS 13.4.1) stopped working a couple weeks ago. When I open the app and I’m logged in, it shows labels for the various programs but no pictures of anything. When I try to open a program, it just goes to a black screen with the title of the program at the top and 3 horizontal dots in the middle, blinking like when a program is loading. It doesn’t matter what type of program I select — Live TV, On-Demand, or DVR Recordings — I get the same 3 blinking dots. I wait and wait but it doesn’t change. I’ve tried everything I can think of... closed the app by swiping it up my screen, restarted my devices, did a hard reset of my devices, deleted the Xfinity Stream app and reloaded it, and even tried a combination of these things. My WiFi is on my home network. I don’t understand why I’m having this problem. Prior to it NOT working it was working perfectly. Can someone please help me?

Highlighted
New Poster

Re: Problem With Xfinity Stream App

Well.... I see I didn’t get any responses but that’s ok because it’s working again! I checked it today and I was so happy to see everything was back to normal. The only thing I can think of that may have “fixed” it is the fact that electrical power was out in my neighborhood yesterday for about an hour. That means no power to both my Xfinity WiFi and X1 TV box. I remember unplugging the TV Box for a few minutes when I originally had the problem so I think it might have been the loss of power to the WiFi box that fixed it