Community Forum

Constantly having remove Roku app to get it to launch

New Poster

Constantly having remove Roku app to get it to launch

About once every 5 to 8 days I go to launch the roku app and it won't launch.  Basically it starts, holds on the initializing screen, then returns back to the roku channel list.  I've even had this happen about 10 minutes after I stopped watching a show, turned things off, then my kids went to watch something. 

The only thing I've found to fix it is to completely remove the app, reinstall the app, and then reauthorize it.  I understand it's beta, but that in its own is ridiculous.  While it's incredibly annoying, my wife constantly reminds me of how annoying it is. 

 

Anyone else having this issue?  I'm accustomed to the AppleTV platform and only have the Roku for the streaming app, so I'm not as familiar with the updating processes.  That being said, as far as I can tell, the Roku is fully up to date as well as the streaming app.

New Poster

Re: Constantly having remove Roku app to get it to launch

I have also had the same problem. The thing that seems to help is to properly exit the app. Use the back arrow on your remote until you see a screen that asks if you want to exit the app.

New Poster

Re: Constantly having remove Roku app to get it to launch

I also have this problem.  Xfinity please fix.

New Poster

Re: Constantly having remove Roku app to get it to launch

I wish that helped me.  Sadly no matter what state the Roku is left in, there is no improvment with having to reauthorize.  I will say, *knocking on wood*, something has happened in the last few weeks where we do not have to uninstall the app as often.  We still have to reauthorize, but removing the app is only a weekly event, not a multiple times per day event.