Community Forum

"We Can't Connect to Your Device" Yet I'm Online?

Highlighted
Regular Contributor

"We Can't Connect to Your Device" Yet I'm Online?

I keep getting a message when I get on my account that Xfinity "can't connect to your device" meaning the modem/router, yet I'm online and having no problem accessing the internet.  When I go to the wireless symbol on my account and check there, the green "everything is okay" shows up.  So what is going on?  Should I restart my modem or just keep ignoring what this message is?  So confusing! (I have a new white Technicolor modem/router which is the XB7 and have had it only a few months after a tech swapped this for our old Arris which we'd had about 15 years.) Any advice on fixing something that isn't broken as I see it?  Thanks, Susan

Highlighted
Official Employee

Re: "We Can't Connect to Your Device" Yet I'm Online?

Hi, FirecrackerGirl. This is interesting! There could be a few reasons for this, which we can look into. Are you using our My Account web portal, using our My Account app, or both? I'm glad to know the service itself is working though, that's definitely a good thing. 🙂 Are you able to provide us with a screenshot of what you're seeing with that error message? You're welcome to use this site: https://comca.st/3oxiTuS to upload it. Please make sure there are no personal details showing, of course. Thanks! We look forward to hearing from you. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!