Community Forum

Paid for internet but says account is deactivated.

Highlighted
New Poster

Paid for internet but says account is deactivated.

I recently set up a new address and paid for internet on May 6th. A technician came out to activate my service and things were working smoothly until this morning. I have no internet and, when I try to connect my router or make changes in my account it says my account is deactivated. This is very frustrating considering I have paid and also I am working from home. Please let me know what I can do to get my account active so I’ll be able to work today. Thank you!
Highlighted
Expert

Re: Paid for internet but says account is deactivated.

 


@Atlian wrote:
I recently set up a new address and paid for internet on May 6th. A technician came out to activate my service and things were working smoothly until this morning. I have no internet and, when I try to connect my router or make changes in my account it says my account is deactivated. This is very frustrating considering I have paid and also I am working from home. Please let me know what I can do to get my account active so I’ll be able to work today. Thank you!

If someone lived there before you chances are they had service they haven't paid for [yet].  An account is not only tied to a person, it's also tied to an address.  You'll need to prove that you're the new resident with either your lease, copy of your mortgage [or closing statement], a utility bill and a current photo ID.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!