Community Forum

Unable to connect to SMTP servers

Highlighted
Regular Visitor

Unable to connect to SMTP servers

Beginning yesterda or so I am unable to send email using my hosts smtp server. This has work fine for ages and suddenly doesn ot. Nothing changed on my end.

 

If I use my cell pohne on Veriszon wireless it is ifne, buto n my Xfinity Wifi on my phone or PC it does not work.

 

I have reached out to them and they say there is nothing on their end, so I am wondering if Xfinity has blacklisted, and if so how to remove:

 

smtp.ionos.com and/or smpt.1and1.com

They use post 587.

I have tried ports 25, 587, and 465 (587 was what i always used)

 

When I try TElnetting ot them, the request seems to try for a while and then fails.. (It is not an immediate failure)

Highlighted
Official Employee

Re: Unable to connect to SMTP servers

@MikeQuimby I've checked our server and we are not blocking or filtering either domain of ionos.com or 1and1.com.

To verify, you are attempting to connect to their SMTP servers? if so, you may want to grab your public IP and reach out to the domains to see if they are denying connections from your IP


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Xfi Advanced Security blocking app

cI see this was already posted, but I see nowhere to comment so I will post again. I have a simalar issue where my Scanner would trigger this when scanning ot SMTP. After 3 hours speaking with 3 different reps who all insisted it was not a Comcast issue, the last guy said I should reset my router. I did that later on in the day and my problem vanished - and then shortly thereafter, reappeared. I repeated this process numerous times until I discovered that it was my scanner - and that disabling the security features "solved" the issue.  Having a security feature that is either on or off - seems counter productive. I have to restrict myself from using my scanner - or diable having the security tools enabled.

 

One would think that allowing users to individually whitelist a "threat" would be a prudent option that should be enacted on the sooner side.

 

It would also have been nice that instead of trying to blame others, they were able to realize (as I had been telling them all along) - that something on THEIR end, not mine, was blacklisting or blocking my SMTP call.

 

They tried to blame Micorsoft of my hositng company - even though I was able ot replcaite the issue by using the same PC and confguration, yet switching from my home Wifi network to the shared Xfinity Wifi network. This should have made it clearly evident that the problem was direclty related to sometihng my Wifi network  - through their router - was doing.