Community Forum

Spam folder

Highlighted
New Poster

Spam folder

All email is now going directly to spam folder on xfinity connect, even though content is no spam. How do I correct

Highlighted
Expert

Re: Spam folder

Check your settings to see if there is a rule set to send everything to Spam.  On the Inbox page click on the gear icon in the upper right corner, then on Settings>>>Mail>>>Filter rules.  If there is such a rule and you didn't put it there, delete it and then change the password on your account as a precaution.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!