Community Forum

Solved: Email client stopped sending mail - Oct 2019

Highlighted
Frequent Visitor

Solved: Email client stopped sending mail - Oct 2019

Problem

My email client stopped sending mail to smtp.comcast.net a few days ago. I read through some posts on this forum and noticed that some people were having success with setting their outgoing mail settings to "auto" security. So I set about discovering exactly what changed on the Comcast servers.

 

Summary

In a nutshell, Comcast is now requiring TLS when connecting to smtp.comcast.net

How you meet that requirement depends on your mail client (the application that you use to send mail). The settings that control security are usually in the same place were you specify the outgoing mail server (smtp options or sending mail). Be sure to use port 587 with smtp.comcast.net

Read on for the gory details of my particular setup.

 

 

 

 


My Client Config

I run Postfix server on a Linux device and it is configured to relay all outgoing mail through smtp.comcast.net. I had previously configured it to use SSL on port 587 which worked for years.

Once Comcast starting requiring TLS my setup stopped working.

As it turns out, TLS is not on by default in my version of Postfix. As noted in the link, the smtp_tls_security_level option should be used with newer versions of Postfix. Set it to 'encrypt' to use TLS with Comcast servers.

Here's my updated SSL/TLS configuration (main.cf):

 

# SASL Authentication to the relay host:
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_security_level = encrypt
smtp_sasl_tls_security_options = noanonymous

 

Hope this helps!

Highlighted
New Poster

Re: Solved: Email client stopped sending mail - Oct 2019

This worked great, fixed my outgoing mail being blocked!

Highlighted
New Poster

Re: Solved: Email client stopped sending mail - Oct 2019

Thank you.  Adding smtp_tls_security_level = encrypt to main.cf and restarting did the trick.

Highlighted
New Poster

Re: Solved: Email client stopped sending mail - Oct 2019

My email client on all my devices (Mac, Iphone, Ipad) suddenly stopped sending emails . There are no warnings of the message not being sent or any other error messages about account setup, and TLS/SSL has been selected in the settings window (it doesn't recognize the account without it).  I have also downloaded Thunderbird and   loaded my email account into Apple mail  on my wife's computer. It acts the same way in all cases. The email acts like it was successfully sent, but the recipient doesn't get it. I've tried this over and over.  The emails send fine off the Xfinity web portal. The strange thing is that this problem ONLY occurs with my email address. If I add my wife's mail account to my mail client..the only settings change being her email address and password.. emails sent from her account on my computer send just fine. I've also added my gmail account to my Apple mail client, and it sends messages from that account perfectly. I've been on the phone with Comcast and of course they have no answer. One agent suggested I contact the "geek squad".  I wanted to strangle that guy. Any ideas, please let me know.

Highlighted
Frequent Visitor

Re: Solved: Email client stopped sending mail - Oct 2019

I was successfully using smtp.comcast.net as a smart host on my Exchange 2003/2010 server for years and years. Suddenly it stopped working. My protocol logs showed a successful connection to smtp.comcast.net. My sender and recipient E-Mail addresses were accepted but the mail never arrived at the intended destination. I enabled TLS as is now required but no go. I switched to a free third-party SMTP provider. I just tried with my Comcast SMTP conector a few days ago and lo and behold it works now. I guess xFinity fixed something on their end.