Community Forum

Sent emails are not getting to recipients

Highlighted
Frequent Visitor

Sent emails are not getting to recipients

Using the Comcast.net email on laptop and iphone.  Suddenly the emails I send are showing as "sent" but not being received by the recipients.  I have read and read until my eyes glzed over, but as I am not using outlook or any other email program, the solutions don't really fit.  The problem happened about 10 days ago then was okay for about 28 hours (without any changes by me) and now it is happening again.  Cannot find a PHONE NUMBER to contact comcast and chat is impossible sinceI no longer have an actual comcast account but only kept my email address when I moved to an area not serviced by Comcast.  Looking for a miracle!  Had this email account for 25+ years......Do a LOT of charity work through this account and don't want to change it now!

Highlighted
Expert

Re: Sent emails are not getting to recipients

If you send a test email to some other account you have like Yahoo or Gmail, does it go through OK?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Thank you for your reply! Yes, and they don’t go through. I waited on hold with Comcast (62 minutes!) today. I am pretty sure their servers think I am a spammer. I send a LOT of emails for charitable work. They started a case and said they will get back to me after checking. (Fingers crossed) I have been dealing with more charity stuff due to COVID19!
Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Sorry! Mis read your reply. I CAN send from gmail etc... apologies! Those DO get to their destination...
Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Nothing FROM Comcast.net address is being delivered
Highlighted
Contributor

Re: Sent emails are not getting to recipients

Same issue here.  Items show in sent mail but recipient never gets it.  Incoming mail working fine.

 

If I reply/send from webmail interface it works fine and makes it to the recipient, but through Outlook 2016 using IMAP (SMTP outbound), it appears to send, even shows in sent items on webmail (so it is making it to Comcast fine), but never makes it to the recipient.

 

I think there is an issue with comcast SMTP servers.  This has been ongoing for several days and am just realizing it now that nobody has gotten my emails.

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

I am only using the web based email exclusively. I have been down for almost three weeks. No call back from Comcast ... day 3 going into day 4.
Highlighted
Contributor

Re: Sent emails are not getting to recipients

Actually it is even stranger, I can REPLY using webmail (connect) and it makes it out fine.  But if I send a brand new message with webmail, it never makes it.

 

Another interesting tidbit, I have 3 comcast email accounts.  Emails from #1 to #2 do not make it to #2 (even emails from #2 to #2 do not work), but from #1 to #3 and #3 to #1 work fine.

 

None of the 3 are able to send to any external email.

 

If I use another PC in another state on another ISP, both new and reply messages make it out to the recipient via webmail/connect using the same account.  I'm assuming that is hitting a different set of servers at Comcast.  So probably there is one set of servers and it is impacting only certain users?  During the COVID crisis email is really critical, this needs to be addressed.  Waiting for a chat agent now.

Highlighted
Contributor

Re: Sent emails are not getting to recipients

@ComcastCSAEmail can you please assist here?  Chat just wanted me to reboot the modem and router.  Obviously if I can reach connnect.xfinity.com fine and send an email, get the message that it was sent successfully, and it shows in sent items, it is nothing to do with my home network.  This is a comcast/xfinity server issue (whether it be the outgoing SMTP server or a hub server etc) somewhere.  There is an email queue that is stuck with probably hundreds/thousands of messages backlogged in it from certain user accounts.

 

During the COVID crisis email is critical, there must be an email team that can look into this and resolve it urgently, or possibly move my 3 email accounts to a different server farm.

 

Chat has opened ticket CR#89218763

 

Thank you

Highlighted
Contributor

Re: Sent emails are not getting to recipients

@ComcastCSAEmail can you please help escalate this?

 

Apparently the original ticket opened via chat didn't go through (or the phone reps aren't able to view chat tickets), I called in and they opened a new one to Tier 2 support.

 

New ticket number 902315925.  They said it could be up to 48 hours for a response but obviously email during this time is pretty important to stay in touch as I live alone, trying to get this back up and running ASAP without having to move over to another email provider.

 

Thanks

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

I spoke with comcast on 4/17/20 11:58a-1:06p central time.  REFERENCE #IH91376309

The service rep said it was being escalated to Tier 2 and that I would hear back from a tech in 24-48 hours.  3 days and counting.  I REALLY NEED THIS TO GET WORKING!  I also have 3 accounts (for the different charities) I can't get them to send nor receive anything from one another.  Thank you yarntrails.  You sound way more tech savvy than I!

Highlighted
Contributor

Re: Sent emails are not getting to recipients

I tried to escalate the ticket, they tried to transfer me to Tier 2 support but I got disconnected twice.  The 3rd agent said they could not transfer me as they were not the original agent that opened the ticket, and I should hear back within 48 hours.  Very frustrating as this is really a critical service during this time.

 

This is actually my mom's account and I'm doing support for her, she lives alone and really needs to stay in touch with people during this time.

 

I did tell them to put in the ticket that there is at least one other person on the forums having the issue and probably several others who just haven't realized it yet (just think people aren't replying or something).  The issue seems to have started sometime around 4/17 for both of us.

Highlighted
Contributor

Re: Sent emails are not getting to recipients

 


@Bethanne6619 wrote:

I spoke with comcast on 4/17/20 11:58a-1:06p central time.  REFERENCE #IH91376309

The service rep said it was being escalated to Tier 2 and that I would hear back from a tech in 24-48 hours.  3 days and counting.  I REALLY NEED THIS TO GET WORKING!  I also have 3 accounts (for the different charities) I can't get them to send nor receive anything from one another.  Thank you yarntrails.  You sound way more tech savvy than I!


You may want to call in again.  The wait time wasn't bad today.  Just to ping them again and maybe escalate the ticket.  The squeaky wheels get the grease as they say.

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

What number are you calling?
Highlighted
Contributor

Re: Sent emails are not getting to recipients

1-800-XFINITY when it asks what I want, I tell it "check status on a ticket".

 

Unfortunately you have to sit through about a 60 second message about COVID and what they're doing.  But after that I got right through.

 


@Bethanne6619 wrote:
What number are you calling?

 

Highlighted
Contributor

Re: Sent emails are not getting to recipients

Just got a call from support asking me "if the issue has been resolved".  But they couldn't tell me if they changed or fixed anything.  Unfortunately my mom is out right now and i can't access her computer to test.

 

You may want to try yours and see if it is working, but not holding my breath, sounds like they aren't sure what the issue is and are hoping it just goes away or something.

 

Hopefully when they call me back (they would not give me a number to call them) she will be home and we can get to the bottom of it.

Highlighted
Contributor

Re: Sent emails are not getting to recipients


@Bethanne6619 wrote:
What number are you calling?

@Bethanne6619 

 

Trying to find something consistent between your account and my mom's.  This seems to be the exact same issue but apparently is not very wide spread.

 

What state are you in?  My mom is in NH.

How old are your email accounts (have they been around a long time)?  Hers are many years old.  EDIT - sorry just noticed from your original post they are quite old, so that is possibly one consistency.

 

Do you have a way to go to the connect.xfinity.com email website from outside of the Comcast network?  Perhaps on a smart phone that is NOT connected to WIFI (using your carrier's mobile network), or maybe someone you know on a different ISP, and try sending an email that way?  The reason I ask is that I can send an email fine from her account when I log into it from my Verizon Fios connection in Mass.  I think when you log in from the Comcast network you may hit a different set of servers than when you're outside of it.  Dunno though, just brainstorming. 

 

EDIT - sorry never mind I see you are not on the Comcast network at all.  Strange that for me I can send fine using her account from outside their network but you can't.

 

Your case is a bit different as you are no longer a customer, not sure if that is related or not.  Wasn't aware they let you keep your account after you cancelled service.  They used to give you a grace period.  Is it indefinite now?

 

Thanks

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Yep. I can continue to use the email as long as I want as long as I log in at least once a month. No problem there! We are in a suburb of Chicago. I just tested it off my WiFi on my phone and SHAZAAM! It worked. What could cause this? I am tech stupid! Thanks so much!!
Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

So, I also logged into my Comcast email from my work computer (remotely from home) and tried it. It worked also! Tested again from home laptop on home WiFi and no go. I have reset my home router a couple of times over the past few weeks+ that this issue has been present without a positive result. Maybe I should try again?
Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Reset home router. Did not help.
Highlighted
Contributor

Re: Sent emails are not getting to recipients

Most major email providers have many client facing servers (what you log into) and the one you get is often based on where you are coming from, your home network goes to one, your phone carrier another one, your work another one, etc.  That is how they balance the load, based on blocks of IP addresses.

 

Each of those front end servers then connects to various back end servers that actually process and send out the mail.  One of those backend servers (or clusters of servers) is having the issue most likely, or possibly the issue lies on the connection between just one set of front end servers and the back end servers.  This is just educated guesses but having worked on email servers in the past it makes sense.  What is odd is that more people aren't having the problem.  I suspect many may have just not realized it yet.  It would make more sense if certain accounts had the issue no matter how they connected as then it would point to one server where those accounts are povisioned having the issue.  This is a bit more complex and strange.

 

This isn't anything to do with your home network, it is something on their end that needs to get fixed.

 

Out of curiosity, if you use your home wifi (that doesn't normally work) and REPLY to a message in your inbox, does it go through?  For my mom, that works for some reason via the connect website, but writing new messages does not.  From her desktop MS Outlook neither one works.

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

I am receiving ALL emails sent to me (which you already know). If I reply to any (and I have tried MANY) none go thru back to the sender I am responding to. I contact each of these persons via text after replying to confirm. This is a difficult problem I only wish COMCAST would look at it and FIX it! I thank you for your very informative input! Deeply appreciated! And your ideas to narrow the problem! now, Comcast, please fix this!!!
Highlighted
Contributor

Re: Sent emails are not getting to recipients


@Bethanne6619 wrote:
I am receiving ALL emails sent to me (which you already know). If I reply to any (and I have tried MANY) none go thru back to the sender I am responding to. I contact each of these persons via text after replying to confirm. This is a difficult problem I only wish COMCAST would look at it and FIX it! I thank you for your very informative input! Deeply appreciated! And your ideas to narrow the problem! now, Comcast, please fix this!!!

Yeah she is getting all emails sent to her as well (at least as far as we know).  For some odd reason some replies seemed to be getting out, at least back to my email that I was testing from.  But new emails composed to my same email address weren't.

They are supposed to call me again tomorrow to continue troubleshooting.

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Please please please let them know about me and my “reference” number! They have not contacted me at all and, because I am no longer a ‘paying’ customer, I fear that I am on the bottom of their list if I am on it at all! I cannot get to a HUMAN on the phone at the xfinity # because I do not have an account number or zip code to match their records. The CSA phone number I call is a minimum wait of an hour as a “non Comcast” customer... I appreciate your digging into this and your thoughts on this bizarre situation! You are a wonderful person! Your mom is a lucky gal!! And I thank you! Best to you and your mom and family(ies)!❤️ Here’s hoping for some results!! 🤞🏻🤞🏻
Highlighted
Contributor

Re: Sent emails are not getting to recipients

Send me a personal message (click my name then the blue "send a message" button on the right of my profile page) with your email addresses and I will relay to them if/when they call.

 

They also ask for 3 external emails you have attempted to email that didn't go through, if you are comfortable providing those I can give them those as well.  But hopefully if they find the problem it will fix all accounts experiencing the issue (hopefully being the operative word).

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Done
Highlighted
Contributor

Re: Sent emails are not getting to recipients

Well after 2.5 hours on the phone this evening, Tier 2 couldn't figure it out, Tier 3 said they see no problem.  Now it is escalated to engineering and they are supposed to be contacting me back.  

 

Really frustrating trying to deal with them but it seems that it is finally getting some attention.

Highlighted
Frequent Visitor

Re: Sent emails are not getting to recipients

Wow. Got my fingers crossed....
Thx for the update!
Highlighted
Contributor

Re: Sent emails are not getting to recipients


@Bethanne6619 wrote:
Wow. Got my fingers crossed....
Thx for the update!

@ComcastCSAEmail was able to fix this.  Apparently my mom's home internet IP address had been flagged for SPAM and that makes Comcast servers apparently SILENTLY drop all emails being sent, without any sort of alert or notification to anyone.  If yours still isn't working you should reach out to them via private message and ask for the same fix.  I have no idea why Chat, Tier 1, Tier 2, and Tier 3 were not able to find this.

 

This now makes sense why it works fine from everything but your (and her) home network, as the filtering was based on IP and not account.

 

There really should be some sort of alert or notification to the user rather than just saying the mail sent successfully.  There is no way to know it didn't go out to the final destination.

 

I'm waiting on confirmation as to whether this block was already on the IP and she just happened to get assigned it a week ago, or if there was something related to her account causing it to get flagged.  She does not send lots of emails and none of them are "spammy" so either this was an IP that had been flagged previously or she has a virus (but I already looked and did not see any spambot like behavior on her computer).

 

A ton of time wasted on something that should have been an easy fix and the user should have been notified how to get it fixed.  There are a few tricks to change your home internet IP address (force it to assign you a new one) and had I known I would have just done that for her. 

Highlighted
New Poster

Re: Sent emails are not getting to recipients

it's now April 26th and I'm having the same problem (for weeks??) I've read the full forum thread, Yarntrails very helpful but I'm still unclear how to actually fix it from my end. Sounds like Comcast is absolutely no help and I'd like to avoid wasting hours going down that rabbit hole. Dismaying absence of customer support when we are all relying on our email to survive! Can somebody provide a step-by-step approach to fix this? I've also been getting a dizzying amount of spam from comcast email addresses telling me to 'verify account' which I just delete (about 5 to 10 every day coming into my inbox). The timing of the two issues seem to correlate and I wonder if that could be the spam that has flagged my account? Should I just close my comcast account and go to gmail?!!

Highlighted
Contributor

Re: Sent emails are not getting to recipients

That was my son replying for me through my yarntrails email account.  After multiple calls and chats and moving up to higher levels, they determined that the IP address my computer was connecting to (in the past few weeks) with outgoing mail--had been blocked from someone who used it in the past for spam.  They unblocked it on Friday and finally my email is actually sending again.  Took a LOT of push from my son.

Highlighted
Contributor

Re: Sent emails are not getting to recipients

If you're getting emails asking you to verify your email you may want to check and see if it gives you some instruction to follow, that may unblock your account.  But just be careful to make sure it is a legit email.  If it gives you a link, rather than clicking it see if you can find the page by logging into your account and see if there is a notice there.  Resolving whatever they're asking you to do may fix it.

 

If not, click on @ComcastCSAEmail and send them a message using the blue button on their profile page and ask them to look into it.  They were the only one who were able to finally get it fixed.

 


@claretone wrote:

it's now April 26th and I'm having the same problem (for weeks??) I've read the full forum thread, Yarntrails very helpful but I'm still unclear how to actually fix it from my end. Sounds like Comcast is absolutely no help and I'd like to avoid wasting hours going down that rabbit hole. Dismaying absence of customer support when we are all relying on our email to survive! Can somebody provide a step-by-step approach to fix this? I've also been getting a dizzying amount of spam from comcast email addresses telling me to 'verify account' which I just delete (about 5 to 10 every day coming into my inbox). The timing of the two issues seem to correlate and I wonder if that could be the spam that has flagged my account? Should I just close my comcast account and go to gmail?!!


 

Highlighted
Regular Visitor

Re: Sent emails are not getting to recipients

I have been having the same problem for months and spent hours and hours in Feb trying to get some solutions. Got  to tier 3 person who mentioned something about an IP address but  he could not fix it. He suggested I go to an xfinity store which I did and they did not have a clue.

I stopped using the email but need to get using it again. Can someone be specific about unblocking the IP . I am not too savy with tech but am able to follow directions. Does it have to be unblocked by comcast?

Thanks and appreciate any help.

Highlighted
Contributor

Re: Sent emails are not getting to recipients

You can't unblock it yourself.  You can try calling support or using chat and specifically tell them you need the spam block removed from your IP address, but unknown if they will be able to do it, as you found previously.

 

You have a few other options 

 

Contact @ComcastCSAEmail by clicking on that blue link, then click the blue button and send them a message.  They seem to know how to unblock it.

 

The other option is (if your router supports it) to clone the MAC address of any computer on the network to the router's WAN port.  Your router manufacturer should have a tutorial on how to do it.  I'm not sure if the Xfinity gateway allows it or not, I don't think they do.  Then reboot your modem and you should get a new IP address.  Again I think this is only an option if you aren't using the Xfinity gateway as your router.

 

The "all else fails" option (if you are renting their gateway) is to bring your gateway in and exchange it for another one.  You will get  a new IP after you provision the new gateway.