Community Forum

Problem sending emails containing sites.google.com links

Highlighted
New Poster

Problem sending emails containing sites.google.com links

I'm having a problem sending emails containing links to Google Sites. I've tried to narrow down the problem in a number of ways. The problem occurs when I'm sending the email from a client app (not the xfinity web site) using a comcast.net account. I've seen it happen with both Apple Mail (on Mac and iPads) and a friend has seen it using Outlook on Windows. The outgoing mail server is set to smtp.comcast.net. Here are the symptoms:

 

- When I send the email to a non-comcast account (e.g., my gmail account) it just never shows up. It does not even appear in my gmail spam folder.

 

- When I send the email to my comcast account it does not show up in my inbox on the xfinity mail web site, however it does show up in my spam folder there (with the link crossed out when I look at the message) and it shows up in my sent folder.

 

Here's how I believe the problem can be reproduced:

 

- Send an email via an Apple Mail client using a comcast account with the outgoing mail server set to smtp.comcast.net. 

 

- The outgoing message contains the string "http://sites.google.com/view/", either in the message text or as the target of a hyperlink. That URL in itself is not a valid sites.google.com link but it is enough to trigger the problem. I tried a number of valid sites links and they all have the problem too. Note that if the message text contains just "sites.google.com/view/" as plain text (no "https://" and no hyperlink when sent from the client side) there is no problem.

 

This problem started happening perhaps in the last couple of months. Emails containing google sites links sent via a mail client using a comcast.net account used to work. Also, sending emails containing google sites links via the xfinity web site directly (no mail client app) does still work.

 

Thanks,
Sharon

 

 

 

 

Highlighted
New Poster

Re: Problem sending emails containing sites.google.com links

Hi Sharon,

 

Did you get a solution or fix for this problem?  Seems like its happening only on my Xfinity App.

 

Thanks

Highlighted
Frequent Visitor

Re: Problem sending emails containing sites.google.com links

I have the same problem and have gotten nowhere with Comcast.  They insist it's Google's problem.  I worked with Google and they say it is the email filters on Comcast's end.  This is beyond maddening.  It just started occurring a few weeks ago.

 

Can't someone at Comcast help???

Highlighted
Official Employee

Re: Problem sending emails containing sites.google.com links

its not a Google issue. It is in fact our filtration system and it is intended. Due to current global situations, scammers have taken initiative to distribute phishing emails containing the mentioned google links(example: Take a Survey and get a $500 Amazon Gift Card! - which redirects to a google survey that asks for SSN,credit card information, etc.). Unfortunately, they are being distributed via compromised accounts and to prevent the distribution of such content, we have a filtration in place to prevent it from happening on our platform. Only time they wont get blocked by the spam filter is if you use the Google service directly to share the content/files/data with. So for example, if you are trying to share a Google Docs form, share it directly via the Google service using the share function to ensure the email gets delivered.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Problem sending emails containing sites.google.com links

Surely your filtering can be tweaked.  It doesn't make sense to tell me I can't use the Comcast email if I want to send someone an email that says, "Here is a link to my mp4 file I want you to see."  and then add the link to my Google Drive where it is stored.

 

I never had trouble doing this until about 2 weeks ago or so.

 

If I can't use Comcast email, then perhaps I don't need to use Comcast at all.  Please check further.

Highlighted
Official Employee

Re: Problem sending emails containing sites.google.com links

I understand how this may be of inconvenience, but unfortunately there is no tweaking to this rule. its in place to protect all Comcast subscribers and their accounts. As you mentioned, "Here is a link to my mp4 file I want you to see." Is also a common tactic to distribute viruses and malware(Along with "here is your DocuSign document", "please review the attachment", "here is your invoice", "i can't believe we caught this video of you", "check out this funny video", "something for you", etc.).

 

As stated, within Google Drive you can directly click on "share" and enter the recipients email address so that Google email servers can directly send the content. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: Problem sending emails containing sites.google.com links

When did this start?  I'm telling you I was ALWAYS able to send emails like this until a couple weeks ago.

Highlighted
Frequent Visitor

Re: Problem sending emails containing sites.google.com links

I'm sorry, but what you are saying does not make sense. I have been sending emails that contain Google Drive links for years. It is just in the last couple of weeks that the same emails go to people's spam folders immediately. In addition, if I send an email to a Gmail address and it contains a Google link, it just disappears. It doesn't go to spam and it doesn't go to the inbox, it just disappears.  I am not the only person with this issue. Others on the forum have said the same thing. I want you to escalate this to get it fixed. Otherwise I will have to file an FCC complaint.