Community Forum

Not Receiving Emails That Have Attachments

Highlighted
Regular Visitor

Not Receiving Emails That Have Attachments

I no longer am receiving email if it has an attachment.  I have sent emails to my Comcast account from Gmail and Yahoo accounts and had other people send me (Comcast and other brands) email with an attachment.  None are coming through or can be found anyone in my mailbox.  Emails without attachment are received without issue. I have checked the Comcast webmail setup, Xfinity Connect on my Android, and Comcast email via Outlook on my laptop.  None are receiving email if it has an attachment, which suggests it's something to do with Comcast.

Highlighted
Gold Problem Solver

Re: Not Receiving Emails That Have Attachments

Are the messages in your webmail Spam folder? If not, check your Spam settings. Make sure that "Enable spam filtering" and "Save a copy of emails marked as spam" are both selected (see https://www.xfinity.com/support/articles/spam-filters-and-email-blocking-new-experience).

If the settings are correct and an employee doesn't reply to your message here, Comcast Security Assurance should be able to help. You can reach them at 1-888-565-4329 (from https://internetsecurity.xfinity.com/help/report-abuse/). Note that this is NOT one of the general customer service numbers.

The first-line reps there are sometimes not very helpful, so you may need to be persistent and keep at them until you get a satisfactory answer.

Highlighted
Regular Visitor

Re: Not Receiving Emails That Have Attachments

Thanks for the tip.  "Enable spam filtering" and "Save a copy of emails marked as spam" are both selected.  In the webmail Gear options, I tried creating a Rule to "Keep" any incoming email with "Attachment."  That has resulted in several test messages with attachments being received.  It feels like a kluge workaround but seems to be working.  Guess we'll the proof will be if it continues to work.