Community Forum


New Poster


on the address bar on emails NOT SECURE

Gold Problem Solver


It's the way most current web browsers are designed. Whenever you use any provider's webmail to open an email that references a non-secure (loaded with "http" instead of "https") image, script, or other item, the browser warns you. In webmail, this probably happens most often if you have the setting for "Allow pre-loading of externally linked images" (gear icon / Settings / Security / Mail) checked. If you don't have that option checked, you're probably getting the browser warning when you open an email that has insecure content and you click the "Show images" button.

Sadly, many of the emails Comcast sends have insecure image links and will trigger the browser's warning. Two examples are "" and "". To a browser both of these are "insecure" because they use "http" instead of "https".

A secure web page that loads insecure content is said to be using "mixed content", and may be subject to a "man-in-the-middle" attack. Comcast seems to think this is not a problem, but Internet security experts think otherwise. See