Community Forum

How to STOP the New Email Notification "Ding" and Preview

CMDaye
New Poster

How to STOP the New Email Notification "Ding" and Preview

I have had Comcast email for 15 years. I access it by logging into a web browser (Safari or Google Chrome) by going to www.comcast.net. In all these years I have never had a pop up notification announcing I have a new email... until today. And it's driving me crazy with the continual "ding" and visual distraction of the pop up preview in the upper right corner.

 

To the best of my knowledge, I did nothing to enable this - it just started. And I can't find how to turn it off. I called Comcast and worked with them for almost two hours today to no avail. Please help me find a way to turn off the notifications for new emails.

 

Thank you in advance to anyone who has an answer!

Latoque
Expert

Re: How to STOP the New Email Notification "Ding" and Preview

 The Comcast webmail interface has no provision for sound notifications of incoming messages, so it's not coming from there.  Are you using Mac Mail or some other client?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
CMDaye
New Poster

Re: How to STOP the New Email Notification "Ding" and Preview

I am on a Macbook Air. I am only using Comcast email. I access it via my browser (Safari). When I am working in other browser tabs, a notification of each email will flash in the upper right corner and "ding." I know it's my Comcast emails because it shows the sender and a bit of the subject line. It just randomly started yesterday and continues today.

jweaver0312
Expert

Re: How to STOP the New Email Notification "Ding" and Preview

Go into your safari preferences for notifications and remove connect.xfinity.com from being allowed to show notifications. It sounds you or someone else may have accidentally granted permission for safari to show Xfinity connect notifications through Notification Center.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
CMDaye
New Poster

Re: How to STOP the New Email Notification "Ding" and Preview

Thank you. It was in there but was set to "deny." I removed it as you advised. Hopefully that gets the job done. No idea how that could have happened accidentally, if that was the case. Truly appreciate your response.

CMDaye
New Poster

Re: How to STOP the New Email Notification "Ding" and Preview

UPDATE: I still have the notification. Still can't find where it's coming from so I can get rid of it. Still looking for any ideas from anyone. Thanks!

CMDaye
New Poster

Re: How to STOP the New Email Notification "Ding" and Preview

Is there anyone from Comcast that monitors this forum and can help me? This shouldn't have to be this hard!

JEM198188
Frequent Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Did you ever find the solution? I have the same problem and switched off out all notification from Safari but still get the ding for new emails!

Latoque
Expert

Re: How to STOP the New Email Notification "Ding" and Preview


@JEM198188 wrote:

Did you ever find the solution? I have the same problem and switched off out all notification from Safari but still get the ding for new emails!


If it's not coming from  Safari, it may be coming from your device settings.  Are you using an iPhone or iPad to access your email?  If so see if this applies to you---------

 

https://www.lifewire.com/how-to-get-vip-email-alerts-in-ios-mail-1172531



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
JEM198188
Frequent Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

I am using a McBook Pro running on Mac OS 10.15.6 and Safari 13.1.2. And this is where the "ding" happens. I also use the Connect App. on an iPhone and Ipad and no notifications there. It only happens on the Computer when I access xfinity connect on Safari. I switched off Safari notification in Settings. But doesn't help.

 

CMDaye
New Poster

Re: How to STOP the New Email Notification "Ding" and Preview

I am still having the problem. And it doesn't matter whether I open Comcast in Safari or in Chrome. It still wants to notify me of every single email that goes into my Comcast email box. My only solution is to keep my computer on mute and ignore the notification in the upper right corner. Would still love to find a solution to turn it off. (and it only happens with Comcast. I will have my Office365 webmail open in a different tab but it never provides notifications.)

amw2
Regular Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Did you ever get a final solution for this?  I am not able to find one either and it is really irritating especially when watching a movie on my macair and the ding keeps going off!

JEM198188
Frequent Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Yes, it took me weeks to figure it out. I used connectxfinity.com on Safari and I also had my comcast email set up on the MacOS Mail app. But I never used the Apple App. The "Ding" actually came from the Apple OS mail app. You can switch it off in the preferences of the mail app "switch off sound effects".

 

amw2
Regular Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Under Settings/Notifications I have set the Email to no sounds but that is maybe not the email you are referring to?  Can you tell me how to locate the Apple email?

amw2
Regular Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

I just want to add that I also have my Comcast email set up on the MacOS email so very similar situation but I don't know how to find the Apple email separately?

JEM198188
Frequent Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Open the preinstalled Apple Mail application on your apple computer. Then go to to top of your screeen, next to the apple icon you click on Mail, then preferences. In the general tab of you find the third box from the top (new messages sound) set to none and below this box uncheck play other mail actions sounds.

JEM198188
Frequent Visitor

Re: How to STOP the New Email Notification "Ding" and Preview

Hope this helped