Community Forum

Embedded Images Not Showing in Emails Received

candtdickens
Regular Visitor

Embedded Images Not Showing in Emails Received

As of January 23, 2021, some of my e-mails do not show the embedded images.  I had this problem last summer but at the time it was resolved by using Microsoft Edge to view my e-mails.  However, my embedded images are not viewable now using Microsoft Edge or Chrome.  How is this resolved?  I am running Windows 10.

Latoque
Expert

Re: Embedded Images Not Showing in Emails Received

Do you mean images in incoming emails in your Comcast account?  If so, it can depend on how the sender composed the message.  I tried using my MSN account to send a photo to my Comcast account by drag-and-dropping the image into the message and it shows up at Comcast as an attachment.  If I do the same thing but use the "Insert image" icon on the toolbar in MSN it shows up in the body of the email.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
candtdickens
Regular Visitor

Re: Embedded Images Not Showing in Emails Received

Yes, it is for incoming emails from businesses like Wayfair, CVS....., but not all businesses.  This was not an issue with Microsoft Edge until January 23, 2021.  We have this same problem if we access our email through Chrome.  Our out going emails are not affected.  Thanks for your reply.

DGM1948
Contributor

Re: Embedded Images Not Showing in Emails Received

I'm having the same issue.  It happened several months ago as well but Comcast caught up to a Chrome update and it resolved.  I switched over to Edge and it was OK and finally esolved on Chrome as well.  I suspect there has been another update and the same thing has happened again.  Happening for me on Chrome and Edge this time. Very frustrating.  It would be great if Comcast could keep up. The last time I was told by Comcast that I should be patient because email is "free" anyway!  As if.

DGM1948
Contributor

Re: Embedded Images Not Showing in Emails Received

As I said earlier, this happened before and Comcast had to catch up with updates on Edge.  Happening on Edge and Chrome.  I had to download Mozilla Firefox for the embedded images to show up on all emails.  Really frustrating to have this happen so much.  Is this being worked on by Comcast to get up to speed with Edge and Chrome??

candtdickens
Regular Visitor

Re: Embedded Images Not Showing in Emails Received

We spoke to a tech at Xfinity yesterday and he found a solution to the problem of embedded images not showing in some e-mails received.  Here is what we did to correct it:  At the Xfinity home page, at the top right where there are 3 dots, left click the dots and in the dropdown go to Settings.   At Settings, inder Privacy And Security left click on Site Settings.  At Site Settings, left click on View permissions and data stored across sites.  Then, left click on xfinity.com.  That will bring a dropdown, in the dropdown left click on emails.xfininty.com.  In that link,  at Ads at the right side it may be on Block.  If it is, switch it to Allow.  In that same link, on Insecure content also on the right side make sure it is on Allow.  When we did both of those things, the e-mails no longer blocked the ad content.  I know it's a lot to do but I hope it is understandable and works for you as it did for us. 

DGM1948
Contributor

Re: Embedded Images Not Showing in Emails Received

Thank you!  I tried this and it resoled my Microsoft Edge Xfinity emails. Will try out my Google Xfinity as well but I use Edge for the most part.  I will save your solution because this has happened before. Seems to happen after some updates.  Thanks again!