Community Forum

Emails sent from Outlook using Office365 domain not being received

Highlighted
Regular Visitor

Emails sent from Outlook using Office365 domain not being received

Starting a couple of days ago all of the emails I have sent are being received by all recipients except for the only person that has a Comcast email address. My ISP is also Comcast but I use Outlook and the Office365 domain

Highlighted
Official Employee

Re: Emails sent from Outlook using Office365 domain not being received

please DM me the domain information so i can look into this for you


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Emails sent from Outlook using Office365 domain not being received

Hi,

I sent you a PM on this as well.

Email sent from our domain's exchange server in outlook 2013, 2007 and 365 aren't going through to you. 

But we are receiving emails sent from you. 

Highlighted
Contributor

Re: Emails sent from Outlook using Office365 domain not being received

@ComcastCSAEmail 
There are NUMEROUS complaints about this - just sort the forum posts by date to see the most current... there would be more or will be more when people begin to realize you are dropping a ton of valid emails...  OFFICE 365 domains, HOTMAIL.COM, LIVE.COM, OUTLOOK.COM are all having issues gettting delivered past your spam filters.

 

TO ANYONE COMCAST USER SEEING THIS POST here is a terrible work-around - go to advanced settings allow SPAM to come thru, at least you will be able to see the messages if you can find them in all the real Junk email COMCAST must block.

 

Capture.JPG
Highlighted
Regular Visitor

Re: Emails sent from Outlook using Office365 domain not being received

Private message sent with requested info. Thanks