Community Forum

Email recipients see “Comcast” rather than My email address

Highlighted
New Poster

Email recipients see “Comcast” rather than My email address

When I send an email from my iphone recipients see it coming from “Comcast” and not my email address.
Called Comcast and tech support had never seen it and had no possible solution. Anyone else experience this and have a solution ? Thanks!
Highlighted
Expert

Re: Email recipients see “Comcast” rather than My email address


@Stemperke wrote:
When I send an email from my iphone recipients see it coming from “Comcast” and not my email address.
Called Comcast and tech support had never seen it and had no possible solution. Anyone else experience this and have a solution ? Thanks!

On the phone, tap the Settings icon on the home screen, then scroll down to "Passwords and accounts".  Tap your Comcast account, and on the next page tap "Account" again.  On the next page what does it say for "Name"?  If it says Comcast tap it and you can change it there.  Make sure you tap "Done" at the top right of the screen.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!