Community Forum

Comcast outgoing mail problem

Highlighted
New Poster

Comcast outgoing mail problem

I got a message saying my password needed to be changed when I tried to login via the web browser.  I changed my password, as required.  Since then, I can recieve mail, but mail I send goes to the sent folder, but the recipient does NOT recieve the email.  It does not work on either the web client or the iphone.  After hours on a chat with Comcast, I rebuilt the mail account about 4 times on my iphone, changed the password several times, but still couldn't get anything to work and left the chat in disgust after being told again to change my password.

 

Questions:

- On the web client, accessed by clicking the email icon on the mail login screen, is there a way to find out the setting for the outgoing SMTP server that is being used?  I wouldn't think this would be necessary, but I want to make sure.

- On the iphone, the port number for the outgoing SMTP server is set to 587 (as of April 9th, 2020).  Is this the correct port?  Other threads has shown the port number has changed through the years.

- I am not getting any error messages of any kind.  The mail says it sends, then just diappeares into the great abyss.  Is there a way to access some kind of log to figure out what's happening?

 

HELP!!!  This is the main email account I've been using for 7 years and I really don't want to have to switch to a new email provider.

Highlighted
Gold Problem Solver

Re: Comcast outgoing mail problem


@Marko63 wrote: ... mail I send goes to the sent folder, but the recipient does NOT recieve the email.  It does not work on either the web client or the iphone. ...

If @ComcastCSAEmail or another employee doesn't reply to your message here, Comcast Security Assurance might be able to help. You can reach them at 1-888-565-4329 (from https://internetsecurity.xfinity.com/help/report-abuse/). Note that this is NOT one of the general customer service numbers. The first-line reps there are sometimes not very helpful, so you may need to be persistent and keep at them until you get a satisfactory answer.


- On the web client ... is there a way to find out the setting for the outgoing SMTP server that is being used? ...

That setting is controlled by the webmail system. Users can't change it or even see it.

 


- On the iphone, the port number for the outgoing SMTP server is set to 587 (as of April 9th, 2020).  Is this the correct port? 

That's correct. See https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email. Did you change the phone's incoming and outgoing passwords to the new one?

Highlighted
Official Employee

Re: Comcast outgoing mail problem

@Marko63 what likely happened is that your account was compromised and sending out spam/phishing emails. This would cause your emails to be blocked from being sent. I've processed a clear for you and should take effect in the next few hours. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Comcast outgoing mail problem

Everything looks like it's working now.  I can't say thank you enough for the help!  DEFINITELY a better experience coming here than what I got going through the chat support option!