Community Forum

Comcast E-mail "Not Secure"

Highlighted
New Poster

Comcast E-mail "Not Secure"

I'm having an issue with my comcast e-mail. When I first load the e-mail page the browser/address bar shows the lock to the left of the address indicating the site is secure.  Once I click on an e-mail however, it shows as being "not secure". This even happens with e-mails I get directly from X-finity. The only way to get the page back to a secure state is to re-fresh or sign out and back in again. But once an e-mail is selected, it reverts back to "not secure". It makes no difference what browser I use. I have tried Chrome, Edge, etc... They all show the same when clicked on an e-mail. I will also add this is the only site I've had the issue with as far as I know. I have tried contacting Comcast and the level 3 tech told me it was normal and he was seeing it on his end as well. This still doesn't sit with me well since I don't think It's "normal" to have an unsecure e-mail showing. I remember seeing another post like this but I don't think it was ever resolved. I'm running a good antivirus as well. I think Comcast needs to really look into this. 

Highlighted
Gold Problem Solver

Re: Comcast E-mail "Not Secure"

Highlighted
New Poster

Re: Comcast E-mail "Not Secure"

It would seem like alot of others are having the issue I guess. The funny thing is if I double-click directly in front of the web address in the browser, it shows an "https" connection. Strange. 

Highlighted
Gold Problem Solver

Re: Comcast E-mail "Not Secure"


@Pinballguy wrote: ... if I double-click directly in front of the web address in the browser, it shows an "https" connection. ...

The connection to Comcast's mail server is secure, but when you open an email, especially if you load images, the links embedded in that email may not be secure (instead of https://image.url it may be http://image.url). To load those page elements the browser switches to non-secure mode, and that's what it's complaining about.

Highlighted
Frequent Visitor

Re: Comcast E-mail "Not Secure"

I've had the same problem for weeks, using Microsoft Edge on a Windows 10 PC.  It occurs when I'm on the following Comcast URL: https:connect.xfinity.com/appsuite/#!!&appp=io.ox/mail&folder=default0/INBOX.

When I click on Not secure, I get the following: Your connection to this site isn't fully secure and it complains about Tracking Prevention, specifically that I need to manage my sites and set it to Balanced tracking, which I do.  It recommends clearing the memory, which I do.  It's frustrating.  Please get on this!