Community Forum

xFi Pods "at no extra cost"

Highlighted
New Poster

xFi Pods "at no extra cost"

So I recieved an email that with my plan (1000mbs) that I can recieve xFi pods at no additional cost and after anaysis of my network, I would greatly improve the coverage and preformance in my home. I attempt to click the link but it says unavialable to me. I contact CS and was told I need to go into my account and add it, but when I do that, the systems doesn't register it as "included" and says I need to pay around $150 bucks to recieve 1 xFi Pod...is this some sort of hussle, trick people into think they can recieve the for free and the hit them with a $150 dollar bill? Seems super unethical and really like a scam. Anyone else experiencing this?

Highlighted
Official Employee

Re: xFi Pods "at no extra cost"

Hi there, @chris0684.

 

Usually, when this happens, it is because the account is not qualified for the xfi pods. I can double-check into your account and see what is happening. Can you please private message me your full name? Thank you for posting to our forums. 
To send a private message, please click my name "ComcastMartin" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: xFi Pods "at no extra cost"

Same thing happened to me and when I called a week ago I was told my order would be expedited. Been a week and not even a notification about the order. Finally got the link to work and ordered the pods myself, with a $15 ‘self install’ fee (WTH?). So the free pods I get after paying for ‘whole home’ service that I’m not getting will cost $15? Hmmmm. And now I’m told the order won’t go through because I have Flex on my account. How does that make any sense? The agent I chatted with yesterday tried to tell me I had to wait 90 days to get the free pods. How does that make any sense? I’d like my whole house to have wifi now, not in three months. Contacted Xfinity about a dozen different times and still keep getting no help. It’s ridiculous that this can’t be cleared up.