Community Forum

Xfinity will not respond to me Xfi Pods return request

Highlighted
New Poster

Xfinity will not respond to me Xfi Pods return request

long story short, I have 3 pods already decided I may need more. I purchased 3 more online and when they arrived, the seal on the box was already broken, none of them would activiate. I spoke with tech support same day, unable to get working. I have followed the guidlines of filling out the online form (several times now). It informs me I will hear from Xfinity with instructions about returning within 48 hours. I have never heard from, even have a dozen requests.  So I called them back and the only thing they would tell me is drop them off at a UPS store but they wouldn't give me an RMA. so just randoming returning something with no account number or RMA would be silly. So it has been over 30 days now and I still need to return this non fuctioning units.

Highlighted
Official Employee

Re: Xfinity will not respond to me Xfi Pods return request

Hi there, @warpedjoe

 

We want to help out in regards to you returning your pod. 

Can you please private message me your full name? Thank you for posting to our forums. 
To send a private message, please click my name "ComcastMartin" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!