Community Forum

SOLUTION for Xfi “Access not authorized”

Highlighted
New Poster

SOLUTION for Xfi “Access not authorized”

I just fixed this problem for myself! (Finally –– horrible customer service from comcast... no one was able to help me) What I did was go to xfinity.com/getstarted. From there, I first took the SSN route and used the last 4 of my social and input my new phone number –– they said no accounts matched the info. It turns out that this was because my email account was associated with my old phone number

 

When I tried finding my xfinity ID again, this time I used my new phone number only (instead of the SSN & phone number route). I confirmed the verification code they texted me, and the system found my other account (with my old phone number) and asked if I wanted to link accounts. I said yes. After linking the accounts, everything was fixed! The app worked and I had my router and WiFi up and running within the next 10 mins. 

 

If someone's having the "access not authorized" problem, it's probably because of mismatched info for the same account confusing the system (different emails for the same phone numbers, or different phone numbers for the same email). Going through xfinity.com/getstarted will allow you to link the accounts.