Community Forum

New construction - site survey wrong answer

Highlighted
Regular Visitor

New construction - site survey wrong answer

Just finishing building a new home in the Denver area. Took many tries, but finally got some at the call center to understand that of course the address doesn't exist in Comcast database, it's NEW. They ordered a site survey, hoped I was making progress. Then I get an automated call back that the sitte survey shows no Comcast in my area.

 

Well I wish I could post pictures, as I have a picture of the Comcast box in my front yard. The Red/Orange Comcast flags in my yard (as they put up flags for all buried services when then were doing a house inspection). The builder ran a 2" conduit from the side of the house to the Comcast box so Comcast could easily pull a line. And inside the Comcast box, it was not locked or sealed, it has the taps from the main Comcast line, with connections to my neighbors and open connections that I assume can be hooked up to my house.

 

What do I do now? How do I convince Comcast that the really do have service in my yard already. I can't find an number to call that won't give me the same "that address does not exist" run around.

 

Can someone from Comcast please help if you are reading these posts.

Highlighted
Official Employee

Re: New construction - site survey wrong answer

Hi there @mhawkey

Can you private message me your address and any associated ticket numbers and photos so I can take a look for you

I am an Official Comcast Employee on the Identity Product Team and the Serviceability team at HQ.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!